Conheça a linguagem de programação LUA e veja como instalar o interpretador!

Conheça a linguagem de programação LUA e veja como instalar o interpretador!

A linguagem de programação LUA tem conquistado os desenvolvedores de programas e aplicações aos poucos, graças a sua simplicidade, leveza e “poder de fogo”, uma vez que pode ser usada para criação de scripts diversos, banco de dados e até programas. 


(adsbygoogle = window.adsbygoogle || []).push({});

Sua diversidade de utilização e portabilidade já conquistaram até mesmo a  Microsoft, que fechou um acordo de parceria com a Pontifícia Universidade Católica do Rio de Janeiro (PUC-Rio), local onde a linguagem nasceu, para integrar a LUA na plataforma .NET.
A linguagem de programação LUA é leve e poderosa, projetada para estender aplicações e usada como uma linguagem de propósito geral. Sua interoperabilidade é capaz de criar pontes entre sistemas diferentes através da criação de novos sistemas que facilitam essas conexões entre ASP e PHP, Windows e Solaris e outros exemplos que se possa pensar. LUA é, na verdade, uma biblioteca escrita em ANSI C compilada sem nenhuma modificação em qualquer plataforma que tenha um compilador compatível com o padrão, como Windows, Solaris, Linux ou Macintosh.
Está instalação abaixo do LUA foi retirado do vivaolinux.
Primeiramente deve ser feita a instalação do interpretador Lua. 
Para quem usa Debian ou alguma distribuição Linux baseada nela, basta dar o comando: 
sudo apt-get install lua 
Você também pode obter o source em:
Ou se preferir, pode baixar com o comando: 
wget http://www.lua.org/ftp/lua-5.3.3.tar.gz
Antes de instalarmos, vamos descompactar: 
tar -vzxf lua-5.3.3.tar.gz 
Depois vá até o diretório criado: 
cd lua-5.3.3 
E lá digite, como root: 
make install 
Pronto, nosso interpretador Lua instá instalado. O uso dele é simples: 
lua codigo.lua 
Vamos agora instalar uma ferramenta para programação antes de começarmos a ter nosso primeiro contato com a linguagem. 
Instale o Geany, que é super completo, e é muito usado para programar com linguagens interpretadas. 
Em uma distribuição Debian ou baseada, baixe-o com o apt-get: 
sudo apt-get install geany 
Caso esteja em outra distribuição, baixe ele por aqui:
Referências:


(adsbygoogle = window.adsbygoogle || []).push({});

você pode gostar também Mais do autor

Comentários