Vulnerabilidade no PHPMailer deixa milhões de sites expostos a ataques remotos

Want create site? Find Free WordPress Themes and plugins.
Vulnerabilidade no PHPMailer deixa milhões de sites expostos a ataques remotos
Uma vulnerabilidade crítica foi descoberta no PHPMailer, que é uma das mais populares bibliotecas PHP open source para o envio de e-mails, utilizado por mais de 9 milhões de usuários no mundo inteiro.
Milhões de sites PHP e aplicativos populares de código aberto, incluindo o WordPress, Drupal, 1CRM, SugarCRM, Yii e Joomla, utilizam o PHPMailer para enviar e-mails usando uma variedade de métodos, incluindo o SMTP para seus usuários.
Descoberto pelo analista de segurança Dawid Golunski da empresa Legal Hackers, a vulnerabilidade crítica (CVE-2016-10033) permite que um invasor execute remotamente um código arbitrário no servidor web e comprometer o sistema por completo.
Golunski relatou a vulnerabilidade para os desenvolvedores, que corrigiram a vulnerabilidade na nova versão do PHPMailer, o PHPMailer 5.2.18.
Todas as versões do PHPMailer antes da versão 5.2.18 são afetadas, portanto os administradores e os desenvolvedores web são recomendados atualizarem para a versão corrigida.
Dawid Golunski não liberou muitos detalhes técnicos sobre a vulnerabilidade, isso porque ele está aguardando que os sites que utilizam uma versão anterior ao PHPMailer 5.2.18, atualizem para versão corrigida.
No entanto, desde a divulgação da vulnerabilidade, milhões de sites permanecem sem correção, se continuar assim, Golunski prometeu liberar mais detalhes técnicos sobre a vulnerabilidade nos próximos dias, incluindo um código de exploração e uma demonstração em vídeo que mostrará o ataque em ação.
Did you find apk for android? You can find new Free Android Games and apps.

Comentários