Notícias sobre Ubuntu, Debian, Fedora, Linux, Android, Tecnologia, LibreOffice e muito mais!

Como instalar e usar o apt-get no Suse/openSUSE Linux!

Tenha o gerenciador de pacotes do Debian no OpenSUSE/SUSE!

Quem esta iniciando no openSUSE/Suse Linux, vai sentir falta do comando APT (Advanced Package Tool). O APT é uma ferramenta que gerencia os pacotes das distribuições Linux como Debian, Ubuntu, Linux Mint e muitas outras. No caso especificamente, o Suse utiliza o Yast ou Yast2.

Quem utiliza OpenSuse, lembre-se que o zypper é um poderoso gerenciador de pacotes, tão bom quanto o APT. Mas, sabemos que quando se migra de distribuições, às vezes, demora algum tempo para que se aprenda tudo novamente, e com a migração, vêm também as mudanças e a curva de aprendizagem.

O ideal é que você aprenda devagar sobre a distribuição, que não se acomode. Mas, é claro, você pode optar por usar outros gerenciadores. Então, desta vez vamos mostrar como instalar o APT no openSUSE/SUSE.

Mas, vale lembrar que o APT vai demorar um pouco mais para montar as listas de dependências no SUSE ou openSUSE. Isso porque o SUSE/openSUSE usa outros padrões diferentes do Debian. Então não estranhe caso o APT passe algum tempo com a mensagem “Reading Package Lists“, saiba que isso acontece normalmente.

Recomendamos o uso do gerenciador nativo de cada distribuição. Mas, se for mais cômodo para você o APT, então use-o, mas até agora o único problema apresentado com o APT em outras distribuições é justamente essa demora, de resto nenhum problemas foi gerado ou encontrado.

Instalação

Para instalar o APT no Linux Suse, basta abrir o terminal (console) e digitar:

# zypper install apt
Lembre-se que é necessário usar o ROOT.
Depois de instalado, você pode editar o arquivo de configuração do APT em: /etc/apt/sources.list e inserir seus repositórios preferidos.

 

Comando APT:

$ apt-get [opções] comando [pacote]

 

Exemplo:

$ apt-get update # apt-get install [pacote que deseja instalar]

 

Espero ter ajudado!
Vale lembrar que não poderá usar os repositórios do Debian. Use necessariamente os do SUSE/openSUSE.

Comentários