Como instalar o Yunit no Ubuntu 16.04 e Debian

O Fork do Unity 8 foi lançado e você pode instalar no Ubuntu ou Debian!

Want create site? Find Free WordPress Themes and plugins.

Yunit é o fork do Unity 8, ele foi criado por um grupo de usuários no intuito de manter código atual do Unity 8 com algumas melhorias como correções e novos recursos. A versão disponível do Yunit é alfa e ainda esta em fase de testes, atualmente pode ser instalado no Ubuntu ou Debian, mas com algumas ressalvas que você ser vista em uma postagem que fizemos hoje em torno do lançamento oficial do Yunit hoje, e neste artigo, você vai ver como instalar o Yunit no Ubuntu 16.04 ou Debian Sid.

Como instalar o Yunit no Ubuntu 16.04 LTS

Com algumas ressalvas, você pode instalar o Yunit no Ubuntu 16.04, Ubuntu GNOME 16.04, Lubuntu 16.04 e no Xubuntu 16.04, porém não poderá instalar no Kubuntu 16.04 ou Ubuntu Mate 16.04, caso tente a instalação em versões não recomendadas o sistema poderá quebrar e você terá grandes problemas.  Aplicativos do KDE ou que usam Qt podem causar incompatibilidade, role até o final da página para ver um exemplo do erro de incompatibilidade.

Para instalar o Yunit nas versões do Ubuntu 16.04 execute os comandos abaixo:

wget -qO - https://archive.yunit.io/yunit.gpg.key | sudo apt-key add
echo 'deb [arch=amd64] http://archive.yunit.io/ubuntu/ xenial main' | sudo tee /etc/apt/sources.list.d/yunit.list
echo 'deb-src http://archive.yunit.io/ubuntu/ xenial main' | sudo tee --append /etc/apt/sources.list.d/yunit.list
sudo apt update
sudo apt upgrade
sudo apt install yunit-desktop

Como instalar o Yunit no Debian

O Yunit pode ser instalado no Debian Sid, que é a versão instável do Debian. A instalação do Yunit foi aprovada nesta versão do Debian devido as versões das bibliotecas e também as dependências requeridas, no entanto, os pacotes de instalação não são os mesmos do Ubuntu, então não seguem os comandos para instalação no Debian.

Para instalar o Yunit no Debian Sid execute os comandos abaixo:

wget -qO - http://archive.yunit.io/yunit.gpg.key | apt-key add -
echo 'deb http://archive.yunit.io/debian/ unstable main' > /etc/apt/sources.list.d/yunit.list
apt update
apt upgrade
apt install unity8-desktop-session unity8-greeter

Para mais informações sobre a instalação do Yunit no Ubuntu ou Debian, por gentileza consulte a documentação oficial do projeto, e para reportar erros, sugestões, acesse o fórum de usuários do Unity:

Documentação de instalação do Yunit no Ubuntu 16.04 LTS

Documentação de instalação do Yunit no Debian Sid

Fórum do Yunit

Caso você encontre o erro abaixo durante a instalação do Yunit, é sinal que SIM você tem alguma aplicação KDE com bibliotecas que não são compatíveis com o Yunit como também você pode estar tentando instalar em um sistema não compatível!
Erro de incompatibilidade:

sudo apt install yunit-desktop
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da “Incoming”.
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
yunit-desktop : Depende: account-plugin-mcloud mas não será instalado
Depende: account-plugin-microsoft mas não será instalado
Depende: account-plugin-nextcloud mas não será instalado
Depende: account-plugin-owncloud mas não será instalado
Depende: address-book-updater mas não será instalado
Depende: libertine mas não será instalado
Depende: libertine-scope mas não será instalado
Depende: ubuntu-keyboard mas não será instalado
Depende: ubuntu-system-settings-libertine mas não será instalado
Depende: ubuntu-upload-manager mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Did you find apk for android? You can find new Free Android Games and apps.

Comentários