in

Canonical corrige vulnerabilidade do PHP em todas as versões do Ubuntu

Confira a lista de pacotes PHP que foram corrigidos em todas as versões do Ubuntu.

Canonical corrige vulnerabilidade do PHP em todas as versões do Ubuntu
Imagem reprodução Linux Hint

Nas últimas semanas, surgiram várias falhas de segurança que é fácil se perder. Na verdade, o que foi descoberto e corrigido tem sido mais ou menos usual, mas dois convidados especiais apareceram: o SWAPGS Attack e um que afetou o ambiente gráfico do Plasma. Algo que se enquadra no “normal” é o que eles corrigiram ontem: uma vulnerabilidade do PHP que afetou todas as versões do Ubuntu.

A Canonical lançou duas versões dos patches para corrigir este bug: uma para as versões naturalmente suportadas, para o Ubuntu 19.04, Ubuntu 18.04 e Ubuntu 16.04, e outra para duas versões que desfrutam de suporte ao ESM ou Extended Security Maintenance, para o Ubuntu 14.04 e o Ubuntu 12.04.

No caso das versões suportadas em seu ciclo de vida normal, a vulnerabilidade foi corrigida no PHP 7.0 e PHP 7.2, enquanto no Ubuntu 14.04 ESM e no Ubuntu 12.04 ESM eles foram resolvidos no PHP5.

Lista de pacotes que foram corrigidos para a vulnerabilidade PHP do Ubuntu

Canonical corrige vulnerabilidade do PHP em todas as versões do Ubuntu
Imagem reprodução Ubunlog

O que eles resolveram foi o mesmo em todas as versões do Ubuntu e seus sabores oficiais: os erros CVE-2019-11041 e CVE-2019-11042 descrevem uma vulnerabilidade do PHP que gerenciou incorretamente certas imagens e pode ser usada para causar negação de serviço (DoS) para causar um bloqueio ou executar um código arbitrário.

Os pacotes que foram atualizados para corrigir este bug são:

No Ubuntu 19.04

libapache2-mod-php7.2 – 7.2.19-0ubuntu0.19.04.2
php7.2-cgi – 7.2.19-0ubuntu0.19.04.2
php7.2-cli – 7.2.19-0ubuntu0.19.04.2
php7.2-fpm – 7.2.19-0ubuntu0.19.04.2
php7.2-xmlrpc – 7.2.19-0ubuntu0.19.04.2

No Ubuntu 18.04 LTS

libapache2-mod-php7.2 – 7.2.19-0ubuntu0.18.04.2
php7.2-cgi – 7.2.19-0ubuntu0.18.04.2
php7.2-cli – 7.2.19-0ubuntu0.18.04.2
php7.2-fpm – 7.2.19-0ubuntu0.18.04.2
php7.2-xmlrpc – 7.2.19-0ubuntu0.18.04.2

No Ubuntu 16.04 LTS

libapache2-mod-php7.0 – 7.0.33-0ubuntu0.16.04.6
php7.0-cgi – 7.0.33-0ubuntu0.16.04.6
php7.0-cli – 7.0.33-0ubuntu0.16.04.6
php7.0-fpm – 7.0.33-0ubuntu0.16.04.6
php7.0-xmlrpc – 7.0.33-0ubuntu0.16.04.6

No Ubuntu 14.04 ESM

libapache2-mod-php5 – 5.5.9+dfsg-1ubuntu4.29+esm5
php5-cgi – 5.5.9+dfsg-1ubuntu4.29+esm5
php5-cli – 5.5.9+dfsg-1ubuntu4.29+esm5
php5-fpm – 5.5.9+dfsg-1ubuntu4.29+esm5
php5-xmlrpc – 5.5.9+dfsg-1ubuntu4.29+esm5

No Ubuntu 12.04 ESM

libapache2-mod-php5 – 5.3.10-1ubuntu3.39
php5-cgi – 5.3.10-1ubuntu3.39
php5-cli – 5.3.10-1ubuntu3.39
php5-fpm – 5.3.10-1ubuntu3.39
php5-xmlrpc – 5.3.10-1ubuntu3.39

Para instalar as atualizações, basta abrir a loja de software do seu Ubuntu, procurar o pacote da versão correta do seu sistema na lista acima e instalar. Embora não pareça necessário, vale a pena reiniciar para garantir que os patches entrem em vigor.

Via: Ubunlog

Written by Fabiano Rodrigues

Usuário de Linux desde o Kurumin 7; servidor público, tecnólogo em análise e desenvolvimento de sistemas, amante de software livre e de código aberto; apaixonado por jogos, louco por rock e heavy metal, filmes e seriados.

Mais da metade das pesquisas do Google não produz um único clique

Mais da metade das pesquisas do Google não produz um único clique

GNU Radio tem nova versão

GNU Radio tem nova versão