Categorias

o-android-13-tem-codinome-interno-vazado-a-aposta-agora-e-a-sobremesa-tiramisu

Android

Games

Notícias

Tutoriais Linux

Vídeos

Tutoriais Linux

06/04/2021 às 07:00

7 min leitura

Avatar Autor
Por Jardeson Márcio

Como instalar o Tablexplore, um analisador de dados, no Ubuntu, Linux Mint, Fedora, Debian

como-instalar-o-tablexplore-um-analisador-de-dados-no-ubuntu-linux-mint-fedora-debian

Tablexplore é um aplicativo para análise de dados e plotagem construído em Python usando o kit de ferramentas PySide2/Qt. Ele usa a classe DataFrame do pandas para armazenar os dados da tabela. Pandas é uma biblioteca Python de código aberto que fornece estruturas de dados de alto desempenho e ferramentas de análise de dados. Saiba como instalar o Tablexplore no linux.

Este aplicativo é destinado principalmente para uso educacional/científico e permite a visualização rápida de dados com plotagem conveniente. O objetivo principal é permitir que os usuários explorem suas tabelas interativamente sem nenhum conhecimento prévio de programação e façam gráficos interessantes enquanto fazem isso.

Com o Tablexplore você pode carregar e trabalhar com tabelas relativamente grandes em comparação com planilhas. O foco está na manipulação de dados, e não na entrada de dados. Embora a edição básica de células e mudanças de linha/coluna sejam suportadas.

Ele conta com diversos recursos, tais como: salvar e carregar projetos; importar csv/hdf/de urls; excluir/adicionar colunas; operações groupby-aggregate/pivot/transpose/melt; mesclar tabelas; mostrar sub-tabelas; plotting geralmente funciona; aplicar funções de coluna, reamostrar, transformar, métodos de string e conversão de data/hora; intérprete python.

Instale-o agora mesmo em seu Linux. Basta seguir o tutorial abaixo e executar a instalação de forma super simples e fácil!

como-instalar-o-tablexplore-um-analisador-de-dados-no-ubuntu-linux-mint-fedora-debian

Instalando o Tablexplore no Ubuntu, Kubuntu, Xubuntu e derivados!

Para instalar o Tablexplore no Ubuntu Linux. Inclusive você também pode instalar o Tablexplore no Linux Mint sem nenhum problema execute o comando abaixo:

sudo snap install tablexplore –beta

Instalando o Tablexplore no Fedora e derivados!

Para instalar o Tablexplore no Fedora, execute os comandos abaixo. Lembrando que caso você já tenha o suporte ao Snap habilitado no Fedora, pule para o passo 3, o de instalação do pacote:

Passo 1 – Instalar o Snapd:

sudo dnf install snapd

Após executar o comando acima, lembre-se encerrar a sessão ou reiniciar o computador! Em seguida, vamos criar um link simbólico para ativar o suporte ao Snap clássico:

Passo 2 – Criar link simbólico:

sudo ln -s /var/lib/snapd/snap /snap

E agora, vamos executar o comando para instalar o Tablexplore no Fedora ou derivados:

Passo 3 – Agora vamos executar o comando para instalar o Tablexplore no Fedora ou derivados:

sudo snap install tablexplore –beta

Instalando o Tablexplore no Debian e derivados!

Para instalar o Tablexplore no Debian, execute os comandos abaixo. Caso você já tenha  Snap ativado e habilitado no seu Debian, pule para o passo 2, que seria da instalação:

Passo 1 – Atualizar os repositório e instalar o Snapd:

apt update
apt install snapd

E agora, vamos executar o comando para instalar o Tablexplore no Debian ou derivados. Observe que o comando abaixo está com o sudo, caso você não o tenha habilitado, remova o sudo e instalar usando o ROOT mesmo:

Passo 2 – Agora vamos executar o comando para instalar o Tablexplore no Debian e derivados:

sudo snap install tablexplore –beta

É isso, esperamos ter ajudado você a instalar o Tablexplore no Linux!

Jardeson é Mestre em Tecnologia Agroalimentar e Licenciado em Ciências Agrária pela Universidade Federal da Paraíba. Entusiasta no mundo tecnológico, gosta de arquitetura e design gráfico. Economia, tecnologia e atualidade são focos de suas leituras diárias. Acredita que seu dia pode ser salvo por um vídeo engraçado.

Últimos artigos

Newsletter

Receba nossas atualizações!

Newsletter

Receba nossas atualizações!
  • Este campo é para fins de validação e não deve ser alterado.