como-instalar-o-visual-studio-code-1-29-no-ubuntu-debian-e-linux-mint

Visual Studio Code 1.29 foi lançado recentemente com muitas correções e melhorias, você pode consultar o anúncio oficial do lançamento antes de seguir com a instalação. Neste artigo, saiba como instalar o Visual Studio Code 1.29 no Ubuntu, Debian e Linux Mint.

Instalando o Visual Studio Code 1.29 no Ubuntu, Debian e Linux Mint

O primeiro passo que precisamos fazer é o download do pacote. Lembramos que neste tutorial vamos usar o sudo para executar os comandos, e com isso, é importante lembrar que o Debian não possui o sudo ativado por padrão, mas você pode seguir o nosso tutorial de como instalar e habilitar o sudo no Debian ou se preferir, executar os comandos como root.

Abra o Terminal e cole o comando abaixo, você pode abri-lo manualmente ou se preferir, utilize o atalho Ctrl + ALT + T:

wget -c https://az764295.vo.msecnd.net/stable/bc24f98b5f70467bc689abf41cc5550ca637088e/code_1.29.1-1542309157_amd64.deb

Se você preferir, pode acessar o site do Visual Studio Code 1.29 e fazer o download via navegador.

Download – Visual Studio Code 1.29

Exemplo da saída no Terminal:

[email protected]:~$ wget https://az764295.vo.msecnd.net/stable/bc24f98b5f70467bc689abf41cc5550ca637088e/code_1.29.1-1542309157_amd64.deb
–2018-11-22 08:20:42– https://az764295.vo.msecnd.net/stable/bc24f98b5f70467bc689abf41cc5550ca637088e/code_1.29.1-1542309157_amd64.deb
Resolvendo az764295.vo.msecnd.net (az764295.vo.msecnd.net)… 192.16.48.200
Conectando-se a az764295.vo.msecnd.net (az764295.vo.msecnd.net)|192.16.48.200|:443… conectado.
A requisição HTTP foi enviada, aguardando resposta… 200 OK
Tamanho: 44745856 (43M) [application/x-debian-package]
Salvando em: “code_1.29.1-1542309157_amd64.deb”

code_1.29.1-1542309157_amd64.deb 100%[=======================================================================>] 42,67M 1,44MB/s em 30s

2018-11-22 08:21:12 (1,44 MB/s) – “code_1.29.1-1542309157_amd64.deb” salvo [44745856/44745856]

Agora vamos iniciar o processo de instalação, no comando abaixo vamos instalar o pacote  baixado, verificar se há necessidade de dependência extra:

sudo dpkg -i ~/code_*.deb; sudo apt -f install -y

Saída de exemplo no Terminal:

[email protected]:~$ sudo dpkg -i ~/code_*.deb; sudo apt -f install -y
(Lendo banco de dados … 189653 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar …/code_1.29.1-1542309157_amd64.deb …
A descompactar code (1.29.1-1542309157) sobre (1.29.1-1542309157) …
dpkg: problemas com dependências impedem a configuração de code:
code depende de libgconf-2-4; porém:
Pacote libgconf-2-4 não está instalado.

dpkg: erro ao processar o pacote code (–install):
problemas de dependência – deixando desconfigurado
A processar ‘triggers’ para gnome-menus (3.13.3-11ubuntu1.1) …
A processar ‘triggers’ para desktop-file-utils (0.23-1ubuntu3.18.04.1) …
A processar ‘triggers’ para mime-support (3.60ubuntu1) …
Erros foram encontrados durante o processamento de:
code
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Corrigindo dependências… Pronto
The following additional packages will be installed:
gconf-service gconf-service-backend gconf2-common libgconf-2-4
Os NOVOS pacotes a seguir serão instalados:
gconf-service gconf-service-backend gconf2-common libgconf-2-4
0 pacotes atualizados, 4 pacotes novos instalados, 0 a serem removidos e 32 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso baixar 845 kB de arquivos.
Depois desta operação, 8.050 kB adicionais de espaço em disco serão usados.
Obter:1 http://br.archive.ubuntu.com/ubuntu bionic/universe amd64 gconf2-common all 3.2.6-4ubuntu1 [700 kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu bionic/universe amd64 libgconf-2-4 amd64 3.2.6-4ubuntu1 [84,8 kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu bionic/universe amd64 gconf-service-backend amd64 3.2.6-4ubuntu1 [58,1 kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu bionic/universe amd64 gconf-service amd64 3.2.6-4ubuntu1 [2.036 B]
Baixados 845 kB em 3s (306 kB/s)
A seleccionar pacote anteriormente não seleccionado gconf2-common.
(Lendo banco de dados … 189653 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar …/gconf2-common_3.2.6-4ubuntu1_all.deb …
A descompactar gconf2-common (3.2.6-4ubuntu1) …
A seleccionar pacote anteriormente não seleccionado libgconf-2-4:amd64.
A preparar para desempacotar …/libgconf-2-4_3.2.6-4ubuntu1_amd64.deb …
A descompactar libgconf-2-4:amd64 (3.2.6-4ubuntu1) …
A seleccionar pacote anteriormente não seleccionado gconf-service-backend.
A preparar para desempacotar …/gconf-service-backend_3.2.6-4ubuntu1_amd64.deb …
A descompactar gconf-service-backend (3.2.6-4ubuntu1) …
A seleccionar pacote anteriormente não seleccionado gconf-service.
A preparar para desempacotar …/gconf-service_3.2.6-4ubuntu1_amd64.deb …
A descompactar gconf-service (3.2.6-4ubuntu1) …
Configurando gconf2-common (3.2.6-4ubuntu1) …

Creating config file /etc/gconf/2/path with new version
Configurando libgconf-2-4:amd64 (3.2.6-4ubuntu1) …
A processar ‘triggers’ para libc-bin (2.27-3ubuntu1) …
Configurando code (1.29.1-1542309157) …
gpg: WARNING: unsafe ownership on homedir ‘/home/emanuel/.gnupg’
Configurando gconf-service (3.2.6-4ubuntu1) …
Configurando gconf-service-backend (3.2.6-4ubuntu1) …

Pronto! O Visual Studio Code 1.29 foi instalado no Ubuntu com sucesso!

Mas, se por algum motivo você queira desinstalar o Visual Studio Code 1.29 execute os comandos abaixo. Observe que com este comando vamos remover o Visual Studio, vamos também verificar se ficou algum pacote órfão e este sera removido.

sudo apt-get remove --autoremove code

Exemplo de saída no Terminal:

[email protected]:~$ sudo apt-get remove –autoremove code
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Os pacotes a seguir serão REMOVIDOS:
code gconf-service gconf-service-backend gconf2-common libgconf-2-4
0 pacotes atualizados, 0 pacotes novos instalados, 5 a serem removidos e 32 não atualizados.
Depois desta operação, 201 MB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
(Lendo banco de dados … 189802 ficheiros e directórios actualmente instalados.)
A remover code (1.29.1-1542309157) …
A remover gconf-service (3.2.6-4ubuntu1) …
A remover gconf-service-backend (3.2.6-4ubuntu1) …
A remover libgconf-2-4:amd64 (3.2.6-4ubuntu1) …
A remover gconf2-common (3.2.6-4ubuntu1) …
A processar ‘triggers’ para mime-support (3.60ubuntu1) …
A processar ‘triggers’ para desktop-file-utils (0.23-1ubuntu3.18.04.1) …
A processar ‘triggers’ para libc-bin (2.27-3ubuntu1) …
A processar ‘triggers’ para gnome-menus (3.13.3-11ubuntu1.1) …
Emanuel Negromonte
Fundador do SempreUPdate. Acredita no poder do trabalho colaborativo, no GNU/Linux, Software livre e código aberto. É possível tornar tudo mais simples quando trabalhamos juntos, e tudo mais difícil quando nos separamos.

Nova versão PlayOnLinux 4.3 foi lançada

Previous article

Como adicionar temas no LibreOffice

Next article

You may also like

More in Linux