in

Computadores da Dell são expostos a falha em aplicativo pré-instalado!

A falha foi identificada no Dell SupportAssist que vem pré-instalado na maioria dos computadores da Dell!

a-maioria-dos-computadores-da-dell-estao-em-risco-devido-a-falha-de-software-pre-instalado

Se você usa um computador Dell, tenha cuidado os hackers podem comprometer seu sistema remotamente. Bill Demirkapi, um pesquisador de segurança independente de 17 anos, descobriu uma vulnerabilidade crítica de execução remota de código no utilitário Dell SupportAssist que vem pré-instalado na maioria dos computadores Dell. Em outras palavras, crackers (hackers mal-intencionados)  podem ter acesso remoto aos computadores ainda com a falha.

O Dell SupportAssist, anteriormente conhecido como Dell System Detect, verifica a integridade do hardware e do software do seu computador. O utilitário foi projetado para interagir com o site de suporte da Dell e detectar automaticamente a etiqueta de serviço ou o código de serviço expresso do seu produto Dell, verificar os drivers de dispositivos existentes e instalar atualizações de drivers ausentes ou disponíveis, além de realizar testes de diagnóstico de hardware.

O Dell SupportAssist funciona em segundo plano e executará um servidor da Web localmente no sistema do usuário, na porta 8884, 8883, 8886 ou 8885, e aceitará vários comandos como parâmetros de URL para executar algumas tarefas predefinidas no computador, como coletar informações detalhadas do sistema ou baixar um software de algum servidor remoto Dell e instalá-lo no sistema automaticamente.

Embora o serviço da Web local seja protegido usando o cabeçalho “Access-Control-Allow-Origin” e tenha algumas validações que o restringem a aceitar comandos apenas do site “dell.com” ou de seus subdomínios, Demirkapi explicou há maneiras de contornar essas proteções em um post publicado em seu GitHub.

A vulnerabilidade de execução remota de código, identificada como CVE-2019-3719, afeta as versões do Dell SupportAssist Client anteriores à versão 3.2.0.90. Antes de publicar os detalhes da vulnerabilidade em público, o pesquisador relatou suas descobertas com responsabilidade à equipe de segurança da Dell, que agora lançou uma versão atualizada do software afetado para resolver o problema.

A Dell confirmou o problema e já lançou a correção, novos testes estão sendo realizados. Ao mesmo tempo, não há relato de volume significativo de pessoas que tiveram problemas reais com crackers.

Além desse problema, a Dell também corrigiu uma vulnerabilidade de validação de origem imprópria (CVE-2019-3718) no software SupportAssist que poderia permitir que um invasor remoto não autenticado tentasse ataques de CSRF nos sistemas dos usuários.

Os usuários da Dell são aconselhados a instalar o Dell SupportAssist 3.2.0.90 ou posterior atualizado ou simplesmente desinstalar completamente o aplicativo, se não for necessário, antes que os hackers tentem explorar a falha, e assim assumir o controle total sobre seus sistemas de computador.

Precisa de mais informações? Consulte um dos links abaixo:

Veja abaixo, uma demonstração em vídeo de como o ataque funciona:

Escrito por Emanuel Negromonte

Fundador do SempreUPdate. Acredita no poder do trabalho colaborativo, no GNU/Linux, Software livre e código aberto. É possível tornar tudo mais simples quando trabalhamos juntos, e tudo mais difícil quando nos separamos.

RPCS3 emulador de PlayStation 3

RPCS3 um emulador de PlayStation 3 para Linux!

Stratis Red Hat ZFS

Conheça o Stratis a nova aposta da Red Hat após o Btrfs