corrigir-erro-de-drivers-nvidia-410-ou-415-apos-uma-atualizacao-recente

Muitos usuários estão comentando via redes sociais que estão tendo um sério problema após atualizar seus drivers proprietários da NVIDIA, a questão é que após atualização nada mais funciona, principalmente o Vulkan. Depois de atualizar para os drivers gráficos NVIDIA versão 410.78 ou 415.18, alguns usuários do Ubuntu, incluindo distribuições baseadas como o Linux Mint, relatam que o Vulkan não funciona mais, quebrando qualquer jogo (por exemplo, qualquer DXVK/Proton) ou aplicativo.

No entanto, alguns usuários lá no Reddit e no Linux Uprising, forneceram algumas possíveis solução, pois por hora não há menção de que correções serão lançadas pela NVIDIA.

Como corrigir erro após atualização dos drivers NVIDIA versão 410.78 ou 415.18

Primeira solução – Tente reinstalar os drivers da Nvidia. Você pode fazer isso usando o Synaptic Package Manager (instalá-lo usando: sudo apt install synaptic), procure por Nvidia, selecione todos os pacotes Nvidia driver instalado, em seguida, vá clicando sobre Mark for Reinstallation a partir do Package menu e, finalmente, clique no botão Apply.

Segunda solução – Veja se o libnvidia-gl-DRIVERVERSION está instalado (este pacote é chamado libnvidia-gl-410 para os drivers Nvidia 410, e libnvidia-gl-415 para os drivers Nvidia 415), e instale-o se ainda não estiver instalado. Você pode checar se este pacote está instalado executando o comando abaixo no Terminal:

apt-cache policy libnvidia-gl-DRIVERVERSION

Terceira solução – Outra maneira de consertar o Vulkan quebrado depois de uma atualização de drivers gráficos Nvidia é modificar o conteúdo do arquivo /usr/share/vulkan/icd.d/nvidia_icd.json . Verifique se este arquivo contém algo assim:

{
"file_format_version" : "1.0.0",
"ICD": {
"library_path": "libGLX_nvidia.so.0",
"api_version" : "1.1.84"
}
}

Se o library_pathvalor for libGL.so.1, substitua-o por libGLX_nvidia.so.0. Uma reinicialização pode ser necessária.

Se o arquivo não existir ou estiver vazio, crie-o usando estes comandos:

sudo mkdir -p /usr/share/vulkan/icd.d
sudo nano /usr/share/vulkan/icd.d/nvidia_icd.json

Vamos usar o editor nano para abrir o arquivo /usr/share/vulkan/icd.d/nvidia_icd.json mas você pode utilizar o que vocÊ estiver mais familiarizado. Cole o seguinte no nvidia_icd.json:

para a Nvidia 410:

{
"file_format_version" : "1.0.0",
"ICD": {
"library_path": "libGLX_nvidia.so.0",
"api_version" : "1.1.82"
}
}

para a Nvidia 415:

{
"file_format_version" : "1.0.0",
"ICD": {
"library_path": "libGLX_nvidia.so.0",
"api_version" : "1.1.84"
}
}

Salve o arquivo (use Ctrl + O, em seguida, Enter e salve-o e, finalmente, Ctrl + X para sair do Nano). Uma reinicialização do sistema pode ser necessária.

Você pode verificar se isso foi corrigido instalando vulkan-tools:

sudo apt install vulkan-tools

E agora, consulte as infmções do Vulkan com o seguinte comando:

vulkaninfo

Se você receber um erro, o suporte do Vulkan será interrompido em sua área de trabalho no Ubuntu ou Linux Mint. Aqui está o erro que alguns usuários recebem quando o arquivo /usr/share/vulkan/icd.d/nvidia_icd.json está vazio:

Saída do Terminal:

$ vulkaninfo
==========
VULKANINFO
==========

Vulkan Instance Version: 1.1.82

vulkaninfo: /build/vulkan-tools-ZnxIl9/vulkan-tools-1.1.82.0+dfsg1/vulkaninfo/vulkaninfo.c:564: AppGetGlobalLayerExtensions: Assertion `!err’ failed.
Aborted (core dumped)

E o erro exibido quando o arquivo /usr/share/vulkan/icd.d/nvidia_icd.json usa em libGL.so.1 em vez de libGLX_nvidia.so.0:

$ vulkaninfo
==========
VULKANINFO
==========

Vulkan Instance Version: 1.1.82

ERROR: [Loader Message] Code 0 : loader_scanned_icd_add: Attempt to retrieve either ‘vkGetInstanceProcAddr’ or ‘vk_icdGetInstanceProcAddr’ from ICD libGL.so.1 failed.
Cannot create Vulkan instance.
/build/vulkan-tools-ZnxIl9/vulkan-tools-1.1.82.0+dfsg1/vulkaninfo/vulkaninfo.c:825: failed with VK_ERROR_INCOMPATIBLE_DRIVER

Bom, esperamos que você tenha corrigido este problema de quebra do Vulkan, após atualização dos drivers NVIDIA, por hora estas são as soluções que estão sendo divulgadas, e esperamos que funcione para você.

Redação
Este usuário é utilizado quando um post é migrado de um usuário para outro, ou quando alguém envia um conteúdo ao SempreUPdate.

    Lançada a primeira atualização do Firefox Reality 1.1

    Previous article

    Descoberta a primeira grande falha de segurança de Kubernetes

    Next article

    You may also like

    More in Dicas