in

Depois de Spectre e Meltdown chega SPOILER, nova falha dos processadores Intel

E o pior de tudo: ainda não há como corrigir o problema. A Intel foi alertada no final do ano passado e não se pronunciou sobre a falha.

Depois de Specter e Meltdown chega SPOILER, nova falha dos processadores Intel

No ano passado, duas grandes e perigosas vulnerabilidades críticas foram descobertas: Meltdown e Spectre. Elas afetam os processadores da Intel e existem, pelo menos, desde  1995, devido à fabricação de CPUs vulneráveis. Assim,  um invasor poderia “enganar” qualquer aplicativo para extrair informações privadas do usuário a partir desses dois problemas de segurança. De lá para cá, os problemas não param de aparecer. Agora, foi descoberto o SPOILER, novo problema nos processadores da Intel.

Como ficou comprovado, a segurança de computadores não depende apenas do software, mas também do design de hardware. Isso é o que ficou claro com essas descobertas. Felizmente, é algo que a Intel resolveu com a 9ª geração dos processadores. Além disso, sistemas operacionais como Windows e Linux fizeram uma atualização que mitigava o problema.

Mesmo assim, tanto a AMD quanto a Intel e a ARM continuam enfrentando os reveses produzidos pela Meltdown e pela Spectre. E no caso da Intel, agora cabe a eles enfrentar uma  nova falha de segurança que eles chamaram de  SPOILER.

Novamente, uma vulnerabilidade em processadores Intel baseados em execução especulativa. O que é isso?

Como verificar se o seu PC está vulnerável a Meltdown e Spectre com Linux

Meltdown e Spectre, embora tenham sido confrontados com patches de segurança, como mencionamos anteriormente, não foram completamente resolvidos. Ambas as vulnerabilidades, uma que afeta os processadores da Intel e outra que afeta os processadores AMD, são baseadas na  execução especulativa. Portanto, isso se repete com a vulnerabilidade recém descoberta, SPOILER, que afeta exclusivamente chips Intel.

A execução especulativa baseia-se em aproveitar os cálculos realizados pelos processadores antecipadamente, para melhorar o desempenho em sua operação e enquanto aguarda a execução dos cálculos atuais. Esse design, e essa função, é o que permite determinar a possibilidade de executar os quadros.

O SPOILER foi descoberto por pesquisadores do Woscester Polytechnic Institute, nos Estados Unidos, em colaboração com a Universidade de Lübeck, na Alemanha. Em um trabalho de pesquisa de ambos os centros de treinamento foi encontrada essa vulnerabilidade crítica dos processadores Intel. Ela foi descoberta  no final do ano passado. Para que se possa atuar em prol da segurança dos usuários, um período de 90 dias foi concedido, o usual nesses casos. No entanto, a Intel não respondeu ao problema.

O que é SPOILER, a nova vulnerabilidade crítica que afeta os processadores Intel da primeira geração

Depois de Spectre e Meltdown chega SPOILER, nova falha dos processadores Intel

SPOILER afeta todos os processadores Intel, começando com a primeira geração de CPUs. E isso afeta apenas os processadores Intel porque usa uma fraqueza em uma tecnologia exclusiva do fabricante.

O SPOILER é uma falha baseada na especulação do endereço de implementação no subsistema de memória. Aproveitando essa falha de segurança, um invasor pode recuperar informações críticas sobre atribuições de páginas físicas aos processos de espaço do usuário.

No caso de uma falha no nível de hardware, para explorar a vulnerabilidade, não importa qual  sistema operacional esteja sendo executado. Na verdade, a falha de segurança pode ser explorada mesmo usando ambientes isolados com segurança ou executando máquinas virtuais. É algo semelhante ao que já foi visto com as vulnerabilidades do Meltdown e do Specter.

Ataques mais rápidos e fáceis

Como explicam no HardZone, o problema tem a ver com as operações de memória na execução especulativa. Um ataque baseado em Rowhammer poderia quebrar a segurança em questão de segundos.

Usando JavaScript para explorar a vulnerabilidade SPOILER, seria um ataque rápido. O pior de tudo é que também não é possível uma solução usando software para resolver o problema completamente. Você pode aplicar patches que atrapalham esse tipo de ataque, porém a falha de segurança está no nível do hardware. Além disso, as soluções de software  afetarão o desempenho.

A Intel não se pronunciou sobre o SPOILER, e não se espera que lance nenhum tipo de atualização para mitigá-lo

Precisamente por causa do que dissemos anteriormente, não é esperado que a atualização de segurança solucione a vulnerabilidade SPOILER. As correções lançadas para o Meltdown e o Spectre resultaram efetivamente em alguma perda de desempenho. Neste caso, embora a Intel tenha sido alertada sobre o problema de segurança no final do ano passado, não houve comunicação oficial sobre o assunto ou um CVE foi emitido.

Mais uma vez, a Intel terá que realizar algumas correções em sua arquitetura e no design de seus microprocessadores. Desta vez, os processadores ARM e AMD não são afetados pelo problema.

Fonte

Escrito por Claylson

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão.

Confira as imagens inéditas do novo Edge baseado no Chromium

Confira as imagens inéditas do novo Edge baseado no Chromium

como-instalar-o-linux-kernel-5-0-no-linux-mint-ubuntu-e-derivados

Como instalar o Linux Kernel 5.0 no Linux Mint, Ubuntu e derivados!