in

Falha de plug-in do WordPress permite controlar sites por completo!

Falha de plug-in do WordPress permite controlar sites por completo!

Certamente, encontrar vulnerabilidades de segurança é uma parte importante para proteger os sites de clientes e melhorar o firewall de aplicativos da web gerenciados. Eventualmente, é isso que o WebARX está analisando nos plug-ins do WordPress. Assim, estão em busca de problemas de segurança e relatando-os posteriormente a desenvolvedores ou organizações competentes. Entãoo, neste post veja que uma falha de plug-in do WordPress permite controlar sites por completo!

Ao fazer a pesquisa, encontramos uma vulnerabilidade no popular plug-in do WordPress, Simple Social Buttons, sendo que, o mesmo permite que usuários não administradores modifiquem as opções de instalação do WordPress.

Visão geral do software

Sabemos que o plugin WordPress Simple Social Buttons é um popular plugin pago e gratuito que possui a possibilidade de adicionar botões de compartilhamento de mídia social na barra lateral, inline, acima e abaixo do conteúdo do post, em fotos, popups, fly-ins.

A princípio, o plugin tem mais de 40.000+ instalações ativas de acordo com o repositório WordPress Plugin e mais de 500.000 downloads de acordo com o fornecedor de plugins WPBrigade.

Descrição da Vulnerabilidade

Primeiramente, o fluxo de design de aplicativo é inadequado, encadeado e com falta de verificação de permissão.

Dessa maneira, resultou em escalonamento de privilégios e ações não autorizadas na instalação do WordPress. Portanto, isso permite que usuários não administradores, até mesmo usuários do assinante, modifiquem as opções de instalação do WordPress na tabela wp_options. Veja a imagem a seguir.

Falha de plug-in do WordPress permite controlar sites por completo!

Como pode ser visto na captura de tela acima, uma função iria iterar pelo objeto JSON fornecido na solicitação.  Além disso, atualizaria todas as opções. Isto seria feito com option_name da object key e option_value de um valor de chave. Tudo sem verificar se o usuário atual tem permissão para gerenciar opções ou desde que option_name pertença a esse plugin.  Além disso, se você quiser saber como se dá a falha, há um vídeo detalhado.

Conclusão

Se o seu site usa o plugin do WordPress “Simple Social Buttons“, você deve atualizá-lo para a versão mais recente o mais rápido possível. Uma vulnerabilidade descrita afeta as versões do plug-in da versão 2.0.4 e anterior à 2.0.22, na qual os desenvolvedores introduziram o patch.

Dessa maneira, a vulnerabilidade foi descoberta e relatada em 7 de fevereiro de 2019. Assim, uma versão corrigida foi lançada apenas um dia depois, em 8 de fevereiro de 2019.

Contudo, os usuários do WebARX estão seguros. Isto porque as regras foram enviadas para o firewall no dia da devida descoberta. No entanto, se você for um usuário do WebARX, certifique-se de atualizar o plug-in o mais rápido possível.

Written by Fábio Trentino

Estudante de Gestão em Tecnologia da Informação na Universidade Centro Universitário Central Paulista - UNICEP - São Carlos - SP

Como sincronizar favoritos entre navegadores diferentes

Como sincronizar favoritos entre navegadores diferentes

KDE Plasma 5.16 começa a ser trabalhado

KDE Plasma 5.16 começa a ser trabalhado