SempreUPdate
Notícias sobre Ubuntu, Debian, Fedora, Linux, Android, Tecnologia, LibreOffice e muito mais!

Falha de segurança da tela de login do Ubuntu pode permitir que qualquer um acesse seus arquivos

Falha afeta os sistemas Ubuntu 16.10 e Ubuntu 17.04

Depois do estrago generalizado causado no mundo Windows pelo ransomware WannaCry, é hora de os usuários do Linux atualizarem seus sistemas e corrigirem uma falha de média prioridade que tem o potencial de causar uma quantidade considerável de danos. A questão que está sendo discutida aqui trata do LightDM, o gerenciador de exibição que alimenta a tela de login do Unity.

Relatado pelo OMGUbuntu!, as versões afetadas são Ubuntu 16.10 e Ubuntu 17.04. Devido a esta falha no LightDM, ele não configura e confina corretamente a sessão do usuário convidado habilitada por padrão no Ubuntu. Explorando o mesmo, um hacker com acesso físico pode pegar os arquivos e obter acesso aos outros usuários no sistema. Observe que os arquivos nos diretórios pessoais de um usuário também podem ser acessados.

Para testar se eles são afetados, os usuários podem simplesmente entrar em uma sessão de convidado, iniciar um terminal com ctrl-alt-t e executar este comando:

$ cat /proc/self/attr/current

Ele deve fornecer o seguinte resultado:

/usr/lib/lightdm/lightdm-guest-session (enforce)

Mas, na realidade, executar o comando na sessão de convidado no Ubuntu 16.10 e 17.04 resulta em:

unconfined

Observe que esse problema foi introduzido quando a manipulação de sessão do usuário foi movida do Upstart para o Systemd no Ubuntu 16.10. É por isso que as versões anteriores ao 16.10 do Ubuntu não são afetadas.

Como corrigir a falha na tela de login do Ubuntu

Apenas no caso de você estar executando um sistema atualizado Ubuntu com todas as atualizações de segurança instaladas, você não precisa se preocupar. Se você não tiver feito isso, você precisa atualizar seu sistema.

Para isso, basta abrir o Gerenciador de atualizações, verificar se há atualizações e instalar todos os patches de segurança listados. Ou então, basta digitar os comandos abaixo:

$ sudo apt update -y && sudo apt upgrade -y

A Canonical também desativou as sessões de convidado por padrão. Ele pode reativar em uma atualização em um futuro próximo, mas é assim que as coisas estão no momento. Se você precisar de sessões de convidado, você precisará ligá-lo manualmente.

Comentários