Notícias

18/11/2021 às 22:00

7 min leitura

Avatar Autor
Por Claylson Martins

Gerenciador de pacotes APT 2.3.12 lançado para evitar quebras constantes

Confira as novidades em relação ao gerenciador.

Gerenciador de pacotes APT 2.3.12 lançado para evitar quebras constantes

A última versão do gerenciador de pacotes APT estava causando muitos problemas para os usuários do Linux. Algumas coisas bem desagradáveis foram registradas por usuários do Pop! _OS, que experimentaram alguns aborrecimentos sérios em relação ao recurso. Assim, o gerenciador de pacotes APT acabou sendo atualizado para evitar que problemas futuros aconteçam.


A situação chegou a tal ponto que a empresa System76, responsável pelo desenvolvimento do sistema operacional Pop!, aplicaria sua própria correção. Isso seria feito de forma emergencial para evitar que um diálogo aparecesse que permitisse aos usuários remover pacotes essenciais. Ao mesmo tempo, o System76 também estava conversando com a equipe do APT para obter uma correção oficial e uma foi criada e lançada com o APT 2.3.12. Portanto, a System76 corrige o APT para Pop! _OS para evitar que os usuários quebrem seus sistemas.

Na época, chegaram até a emitir um comunicado oficial:

Por alguma razão, uma versão i386 de um pacote nunca foi publicada no Launchpad. O Steam sendo um pacote i386, ao tentar instalá-lo, ele teve que fazer o downgrade desse pacote para a versão Ubuntu para resolver dependências, o que removeu os pacotes Pop! _OS.

Gerenciador de pacotes APT 2.3.12 lançado para evitar quebras constantes
Gerenciador de pacotes APT 2.3.12 lançado para evitar quebras constantes

O problema não deveria ter surgido com frequência e foi o resultado da quebra do pacote Steam, com o APT no terminal mencionando muitas coisas diferentes que poderiam facilmente confundir os usuários. Para continuar, você precisava inserir “Sim, faça o que eu digo!” para o progresso, o que você provavelmente nunca deveria fazer, já que o aviso estava lá por uma razão – pacotes essenciais sendo removidos.

Gerenciador de pacotes APT 2.3.12 lançado para evitar quebras constantes


Agora, essa opção foi removida e o APT não terá mais sua tentativa de solucionador de remover pacotes essenciais ou protegidos, então qualquer problema de dependência precisa ser resolvido manualmente. Como resultado, seu pacote não será instalado, removido ou atualizado se houver conflitos, mas pelo menos você tem um sistema real funcionando . Ele ainda pode ser sobrescrito, mas não dirá explicitamente como fazer isso na mensagem de erro para evitar que as pessoas simplesmente façam isso de novo.

Parece que o Pop! _OS  está se preparando para fazer as mudanças. É provável que outras distribuições usando APT sigam durante seus padrões de atualização regulares.

Ainda sobre jogos

No lado da NVIDIA, para o Vulkan Beta 470.62.12 voltado para o desenvolvedor, eles adicionaram suporte para essas novas extensões:

Além disso, as APIs de vídeo Vulkan foram atualizadas para a versão 1.2.199 e também atualizaram os recursos de vídeo Vulkan de acordo com as novas especificações de vídeo. Além disso, há correções para atômicos de 64 bits que não funcionam sob algumas condições e o driver agora também lida com o VkRenderingFragmentShadingRateAttachmentInfoKHR.imageView. Com um VK_NULL_HANDLE corretamente.

Nota: como é voltado para desenvolvedores, os usuários da NVIDIA geralmente irão querer ficar com seus drivers principais com 495,44 ou 470,86.

Via GamingonLinux

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão. Nas horas não muito vagas, professor, fotógrafo, apaixonado por rádio e natureza.

Últimos artigos

Newsletter

Receba nossas atualizações!

Newsletter

Receba nossas atualizações!
  • Este campo é para fins de validação e não deve ser alterado.