Dicas

Instalar o Editor de Vídeo Flowblade 2.0 no Debian

0

O editor de vídeo são geralmente usados em agências de conteúdo audiovisual, empresas de comunicação e publicidade, para edição de vídeos de divulgação da empresa ou de seus parceiros.

O grande crescimento dos conteúdos em vídeo de uns tempos pra cá, por conta dos algoritmos das redes sociais e a maior percepção de que somos seres visuais, é uma área muito explorada nos dias de hoje.

Com essa introdução acima, vamos saber quem é esse Flowblade e ver como instalar o editor de vídeo Fowblade 2.0 no Debian.

Flowblade

O Flowblade é um editor de vídeo não linear multitrack para Linux lançado sob a licença GPL 3.

Com o Flowblade Movie Editor, você pode compor filmes a partir de videoclipes, clipes de áudio e arquivos gráficos. Os clipes podem ser cortados nos quadros desejados, os filtros podem ser adicionados aos clipes e você pode criar imagens compostas multicamadas usando objetos de composição.

O Flowblade oferece um fluxo de trabalho (conjunto de ferramentas e certos comportamentos de linha do tempo) configurável pelo usuário. Ele suporta todas as mídias que em geral podem ser acessadas em um sistema Linux quando a biblioteca FFMPEG está funcionando como back-end.

Instalar o Editor de Vídeo Flowblade 2.0 no Debian

Nessa dica estamos usando o Debian 9 Stretch mas servirá para a maioria das distribuições baseadas no Debian.

1. Versões do Flowblade

O Flowblade no repositório do Debian 9 Stretch está com sua versão stable 1.10. Veja com o comando abaixo:

apt search flowblade
saída:
apt search flowblade
Sorting… Pronto
Full Text Search… Pronto
flowblade/stable,stable 1.10-2 all
editor de vídeo não-linear
As versões disponível no site do projeto até o momento dessa dica.
  • Última versão lançada em fevereiro de 2019

Flowblade Movie Editor 2.0

  • Próxima versão prevista para junho de 2019

O Flowblade Movie Editor 2.2

2. Instalar o Flowblade 2.0

Como o Flowblade no repositório do Debian Sretch está muito atrás, assim vamos instalar o Flowblade 2.0 seguindo os passos de instalação via pacote .deb ou flatpak.

2.1 Instalar Flowblade (pacote DEB)

Para instalar o pacote Flowblade 2.0, vamos no botão abaixo baixar o pacote .deb para o Debian.

Download Flowblade 2.0

Para instalação do pacote deveremos ter privilégio de root. Assim, podemos instalar com o comando abaixo.

dpkg -i flowblade-2.0.0-1_all.deb
Saída:
A seleccionar pacote anteriormente não seleccionado flowblade.
(Lendo banco de dados … 270501 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar flowblade-2.0.0-1_all.deb …
A descompactar flowblade (2.0.0-1) …
dpkg: problemas com dependências impedem a configuração de flowblade:
flowblade depende de python-mlt | python-mlt5 | python-mlt2; porém:
Pacote python-mlt não está instalado.
Pacote python-mlt5 não está instalado.
Pacote python-mlt2 não está instalado.
flowblade depende de frei0r-plugins; porém:
Pacote frei0r-plugins não está instalado.
flowblade depende de swh-plugins; porém:
Pacote swh-plugins não está instalado.
flowblade depende de libmlt-data; porém:
Pacote libmlt-data não está instalado.
flowblade depende de gmic; porém:
Pacote gmic não está instalado.

dpkg: erro ao processar o pacote flowblade (–install):
problemas de dependência – deixando desconfigurado
A processar ‘triggers’ para mime-support (3.60) …
A processar ‘triggers’ para gnome-menus (3.13.3-9) …
A processar ‘triggers’ para desktop-file-utils (0.23-1) …
A processar ‘triggers’ para man-db (2.7.6.1-2) …
A processar ‘triggers’ para menu (2.1.47+b1) …
A processar ‘triggers’ para shared-mime-info (1.8-1+deb9u1) …
Erros foram encontrados durante o processamento de:
flowblade

Com o retorno do comando, tivemos problemas de dependências ao instalar o pacote, sendo assim, vamos corrigir as dependências forçando a instalação com suas dependências com o comando abaixo:

apt install -f
Saída:
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Corrigindo dependências… Pronto
The following additional packages will be installed:
frei0r-plugins gmic libgavl1 libmlt++3 libmlt-data libmlt6 libmovit5 libopencv-contrib2.4v5
libopencv-gpu2.4v5 libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-ocl2.4v5
libopencv-photo2.4v5 libopencv-stitching2.4v5 libopencv-superres2.4v5 libopencv-ts2.4v5
libopencv-videostab2.4v5 librtaudio5a libsox-fmt-alsa libsox-fmt-base libsox2 python-mlt
swh-plugins
Pacotes sugeridos:
opencv-data gimp-gmic gmic-zart libsox-fmt-all
Os NOVOS pacotes a seguir serão instalados:
frei0r-plugins gmic libgavl1 libmlt++3 libmlt-data libmlt6 libmovit5 libopencv-contrib2.4v5
libopencv-gpu2.4v5 libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-ocl2.4v5
libopencv-photo2.4v5 libopencv-stitching2.4v5 libopencv-superres2.4v5 libopencv-ts2.4v5
libopencv-videostab2.4v5 librtaudio5a libsox-fmt-alsa libsox-fmt-base libsox2 python-mlt
swh-plugins
0 pacotes atualizados, 23 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso baixar 11,0 MB de arquivos.
Depois desta operação, 65,8 MB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] S
Obter:1 http://deb.debian.org/debian stable/main amd64 libmovit5 amd64 1.4.0-1 [164 kB]
Obter:2 http://deb.debian.org/debian stable/main amd64 librtaudio5a amd64 4.1.2~ds0-4 [43,5 kB]
Obter:3 http://deb.debian.org/debian stable/main amd64 libsox2 amd64 14.4.1-5+b2 [261 kB]
Obter:4 http://deb.debian.org/debian stable/main amd64 libmlt6 amd64 6.4.1-4 [588 kB]
Obter:5 http://deb.debian.org/debian stable/main amd64 libmlt++3 amd64 6.4.1-4 [142 kB]
Obter:6 http://deb.debian.org/debian stable/main amd64 python-mlt amd64 6.4.1-4 [199 kB]
Obter:7 http://deb.debian.org/debian stable/main amd64 libgavl1 amd64 1.4.0-4 [3.361 kB]
Obter:8 http://deb.debian.org/debian stable/main amd64 libopencv-ml2.4v5 amd64 2.4.9.1+dfsg1-2 [196 kB]
Obter:9 http://deb.debian.org/debian stable/main amd64 libopencv-contrib2.4v5 amd64 2.4.9.1+dfsg1-2 [294 kB]
Obter:10 http://deb.debian.org/debian stable/main amd64 libopencv-legacy2.4v5 amd64 2.4.9.1+dfsg1-2 [405 kB]
Obter:11 http://deb.debian.org/debian stable/main amd64 libopencv-photo2.4v5 amd64 2.4.9.1+dfsg1-2 [53,0 kB]
Obter:12 http://deb.debian.org/debian stable/main amd64 libopencv-gpu2.4v5 amd64 2.4.9.1+dfsg1-2 [50,6 kB]
Obter:13 http://deb.debian.org/debian stable/main amd64 libopencv-ocl2.4v5 amd64 2.4.9.1+dfsg1-2 [444 kB]
Obter:14 http://deb.debian.org/debian stable/main amd64 libopencv-stitching2.4v5 amd64 2.4.9.1+dfsg1-2 [170 kB]
Obter:15 http://deb.debian.org/debian stable/main amd64 libopencv-superres2.4v5 amd64 2.4.9.1+dfsg1-2 [69,7 kB]
Obter:16 http://deb.debian.org/debian stable/main amd64 libopencv-ts2.4v5 amd64 2.4.9.1+dfsg1-2 [230 kB]
Obter:17 http://deb.debian.org/debian stable/main amd64 libopencv-videostab2.4v5 amd64 2.4.9.1+dfsg1-2 [84,3 kB]
Obter:18 http://deb.debian.org/debian stable/main amd64 frei0r-plugins amd64 1.5.0-1 [389 kB]
Obter:19 http://deb.debian.org/debian stable/main amd64 swh-plugins amd64 0.4.17-2 [444 kB]
Obter:20 http://deb.debian.org/debian stable/main amd64 libmlt-data all 6.4.1-4 [1.365 kB]
Obter:21 http://deb.debian.org/debian stable/main amd64 gmic amd64 1.7.9+zart-4 [1.965 kB]
Obter:22 http://deb.debian.org/debian stable/main amd64 libsox-fmt-alsa amd64 14.4.1-5+b2 [47,1 kB]
Obter:23 http://deb.debian.org/debian stable/main amd64 libsox-fmt-base amd64 14.4.1-5+b2 [68,8 kB]
Baixados 11,0 MB em 18s (605 kB/s)
A seleccionar pacote anteriormente não seleccionado libmovit5:amd64.
(Lendo banco de dados … 271506 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar …/00-libmovit5_1.4.0-1_amd64.deb …
A descompactar libmovit5:amd64 (1.4.0-1) …
A seleccionar pacote anteriormente não seleccionado librtaudio5a:amd64.
A preparar para desempacotar …/01-librtaudio5a_4.1.2~ds0-4_amd64.deb …
A descompactar librtaudio5a:amd64 (4.1.2~ds0-4) …
A seleccionar pacote anteriormente não seleccionado libsox2:amd64.
A preparar para desempacotar …/02-libsox2_14.4.1-5+b2_amd64.deb …
A descompactar libsox2:amd64 (14.4.1-5+b2) …
A seleccionar pacote anteriormente não seleccionado libmlt6.
A preparar para desempacotar …/03-libmlt6_6.4.1-4_amd64.deb …
A descompactar libmlt6 (6.4.1-4) …
A seleccionar pacote anteriormente não seleccionado libmlt++3.
A preparar para desempacotar …/04-libmlt++3_6.4.1-4_amd64.deb …
A descompactar libmlt++3 (6.4.1-4) …
A seleccionar pacote anteriormente não seleccionado python-mlt.
A preparar para desempacotar …/05-python-mlt_6.4.1-4_amd64.deb …
A descompactar python-mlt (6.4.1-4) …
A seleccionar pacote anteriormente não seleccionado libgavl1:amd64.
A preparar para desempacotar …/06-libgavl1_1.4.0-4_amd64.deb …
A descompactar libgavl1:amd64 (1.4.0-4) …
A seleccionar pacote anteriormente não seleccionado libopencv-ml2.4v5:amd64.
A preparar para desempacotar …/07-libopencv-ml2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-ml2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado libopencv-contrib2.4v5:amd64.
A preparar para desempacotar …/08-libopencv-contrib2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-contrib2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado libopencv-legacy2.4v5:amd64.
A preparar para desempacotar …/09-libopencv-legacy2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-legacy2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado libopencv-photo2.4v5:amd64.
A preparar para desempacotar …/10-libopencv-photo2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-photo2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado libopencv-gpu2.4v5:amd64.
A preparar para desempacotar …/11-libopencv-gpu2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-gpu2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado libopencv-ocl2.4v5:amd64.
A preparar para desempacotar …/12-libopencv-ocl2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-ocl2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado libopencv-stitching2.4v5:amd64.
A preparar para desempacotar …/13-libopencv-stitching2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-stitching2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado libopencv-superres2.4v5:amd64.
A preparar para desempacotar …/14-libopencv-superres2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-superres2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado libopencv-ts2.4v5:amd64.
A preparar para desempacotar …/15-libopencv-ts2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-ts2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado libopencv-videostab2.4v5:amd64.
A preparar para desempacotar …/16-libopencv-videostab2.4v5_2.4.9.1+dfsg1-2_amd64.deb …
A descompactar libopencv-videostab2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A seleccionar pacote anteriormente não seleccionado frei0r-plugins.
A preparar para desempacotar …/17-frei0r-plugins_1.5.0-1_amd64.deb …
A descompactar frei0r-plugins (1.5.0-1) …
A seleccionar pacote anteriormente não seleccionado swh-plugins.
A preparar para desempacotar …/18-swh-plugins_0.4.17-2_amd64.deb …
A descompactar swh-plugins (0.4.17-2) …
A seleccionar pacote anteriormente não seleccionado libmlt-data.
A preparar para desempacotar …/19-libmlt-data_6.4.1-4_all.deb …
A descompactar libmlt-data (6.4.1-4) …
A seleccionar pacote anteriormente não seleccionado gmic.
A preparar para desempacotar …/20-gmic_1.7.9+zart-4_amd64.deb …
A descompactar gmic (1.7.9+zart-4) …
A seleccionar pacote anteriormente não seleccionado libsox-fmt-alsa:amd64.
A preparar para desempacotar …/21-libsox-fmt-alsa_14.4.1-5+b2_amd64.deb …
A descompactar libsox-fmt-alsa:amd64 (14.4.1-5+b2) …
A seleccionar pacote anteriormente não seleccionado libsox-fmt-base:amd64.
A preparar para desempacotar …/22-libsox-fmt-base_14.4.1-5+b2_amd64.deb …
A descompactar libsox-fmt-base:amd64 (14.4.1-5+b2) …
Configurando swh-plugins (0.4.17-2) …
Configurando libopencv-ml2.4v5:amd64 (2.4.9.1+dfsg1-2) …
Configurando libmovit5:amd64 (1.4.0-1) …
Configurando libopencv-legacy2.4v5:amd64 (2.4.9.1+dfsg1-2) …
Configurando libopencv-ts2.4v5:amd64 (2.4.9.1+dfsg1-2) …
Configurando libopencv-contrib2.4v5:amd64 (2.4.9.1+dfsg1-2) …
Configurando libmlt-data (6.4.1-4) …
Configurando libgavl1:amd64 (1.4.0-4) …
Configurando libsox2:amd64 (14.4.1-5+b2) …
A processar ‘triggers’ para libc-bin (2.24-11+deb9u3) …
Configurando librtaudio5a:amd64 (4.1.2~ds0-4) …
Configurando libopencv-ocl2.4v5:amd64 (2.4.9.1+dfsg1-2) …
A processar ‘triggers’ para man-db (2.7.6.1-2) …
Configurando libopencv-photo2.4v5:amd64 (2.4.9.1+dfsg1-2) …
Configurando libsox-fmt-base:amd64 (14.4.1-5+b2) …
Configurando libsox-fmt-alsa:amd64 (14.4.1-5+b2) …
Configurando libopencv-gpu2.4v5:amd64 (2.4.9.1+dfsg1-2) …
Configurando libopencv-stitching2.4v5:amd64 (2.4.9.1+dfsg1-2) …
Configurando libopencv-videostab2.4v5:amd64 (2.4.9.1+dfsg1-2) …
Configurando libopencv-superres2.4v5:amd64 (2.4.9.1+dfsg1-2) …
Configurando gmic (1.7.9+zart-4) …
Configurando frei0r-plugins (1.5.0-1) …
Configurando libmlt++3 (6.4.1-4) …
Configurando libmlt6 (6.4.1-4) …
Configurando python-mlt (6.4.1-4) …
Configurando flowblade (2.0.0-1) …
A processar ‘triggers’ para libc-bin (2.24-11+deb9u3) …
A processar ‘triggers’ para menu (2.1.47+b1) …

Agora o Flowblade 2.0 já estará disponível no Menu > Multimídia > Flowblade Movie Editor.

2.1 Instalar Flowblade (pacote FLATPAK)

Para instalar o pacote flatpak, o sistema já deverá ter o pacote flatpak instalado, caso ainda não tenha, instale-o com o comando abaixo:

apt install flatpak

Após a instalação do flatpak vamos ativar o repositório do Flathub com o comando abaixo:

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

Agora que já temos o flatpak instalado e configurado, vamos instala o Flowblade com o comando abaixo:

flatpak install --dehttps: //flathub.org/repo/appstream/io.github.jliljebl.Flowblade.flatpakref
Saída:

Instalando: io.github.jliljebl.Flowblade/x86_64/stable
Required runtime for io.github.jliljebl.Flowblade/x86_64/stable (org.gnome.Platform/x86_64/3.30) is not installed, searching…
Found in remote flathub, do you want to install it? [y/n]: y
Instalando: org.gnome.Platform/x86_64/3.30 de flathub

10 delta parts, 110 loose fetched; 307202 KiB transferred in 412 seconds
Instalando: org.gnome.Platform.Locale/x86_64/3.30 de flathub

25 metadata, 141 content objects fetched; 4469 KiB transferred in 6 seconds
Instalando: org.freedesktop.Platform.GL.nvidia-410-78/x86_64/1.4 de flathub

1 delta parts, 2 loose fetched; 347 KiB transferred in 14 seconds Instalando: org.freedesktop.Platform.html5-codecs/x86_64/18.08 de flathub

1 delta parts, 3 loose fetched; 2492 KiB transferred in 3 seconds
Instalando: io.github.jliljebl.Flowblade/x86_64/stable de flathub

5 delta parts, 81 loose fetched; 87436 KiB transferred in 117 seconds
Instalando: io.github.jliljebl.Flowblade.Locale/x86_64/stable de flathub

11 metadata, 5 content objects fetched; 160 KiB transferred in 1 seconds

Acabando a instalação, da mesma forma o Flowblade se encontra no Menu > Multimídias > Flowblade Movie Editor.

Flowblade - Tela de boas vindas.

Flowblade – Tela de boas vindas.

Flowblade - Pronto para ser usado.

Flowblade – Pronto para ser usado.

Pronto! Editor de vídeo Flowblade 2.0 instalado para já poder ser feito as edições ou criações de conteúdo de vídeos.

Siga-nos no Twitter para receber atualizações e no Telegram para comentar, receber suporte e tirar dúvida.

Até a próxima.

Glauber GF
Graduando em Sistemas de Informação, militante de software livre, usuário assíduo do sistema GNU/Linux e também membro do Viva o Linux.

Como instalar o Picapy, um gerenciador para o Picasa Web no Ubuntu

Previous article

A censura escondida de igualdade: O que pode estar por trás do novo CoC? Part.2

Next article

You may also like

More in Dicas