in

Problemas de segurança no OpenJPEG podem causar falhas no Ubuntu 18.04

A falha pode causar negação de serviço.

Problemas de segurança no OpenJPEG podem causar falhas no Ubuntu 18.04

 A Canonical publicou um relatório detalhando 5 falhas de segurança na descompactação da biblioteca de compactação openjpeg2 – JPEG 2000. Isso poderia causar o travamento do Ubuntu ou algo pior. Inicialmente, os bugs encontrados no OpenJPEG afetam apenas o Ubuntu 18.04 LTS. Então, as outras duas versões oficiais que ainda têm suporte oficial, que são Ubuntu 16.04 Xenial Xerus (corrigido no passado) e Ubuntu 19.04, estão livres de qualquer problema. Então, problemas de segurança no OpenJPEG podem causar falhas no Ubuntu 18.04

Ao contrário do que alguns pesquisadores de segurança fazem para publicar as vulnerabilidades antes de serem corrigidas, a Canonical só publica falhas de segurança quando os patches já foram liberados. No total, 5 bugs foram corrigidos. Todos esses problemas podem ser usados ??para causar negação de serviço (DoS). Em uma das falhas, eles também mencionam que isso poderia permitir a execução remota de código.

Problemas de segurança no OpenJPEG podem causar falhas no Ubuntu 18.04Problemas de segurança no OpenJPEG podem causar falhas no Ubuntu 18.04

As correções de erros foram:

  • CVE-2017-17480: foi descoberto que o OpenJPEG lidava com certos arquivos PGX incorretamente. Um invasor pode usar essa falha para causar negação de serviço ou executar a execução remota de código.
  • CVE-2018-14423: foi descoberto que o OpenJPEG lidava com certos arquivos incorretamente. Um invasor pode usar essa falha para causar negação de serviço.
  • CVE-2018-18088: foi descoberto que o OpenJPEG manipulava certos arquivos PNM incorretamente. Um invasor pode usar essa falha para causar negação de serviço.
  • CVE-2018-5785 e CVE-2018-6616: o OpenJPEG também manipulou alguns arquivos BMP incorretamente. Um invasor pode usar a falha para causar negação de serviço.

Os patches que resolvem estes 5 bugs estão agora disponíveis nos repositórios oficiais do Ubuntu 18.04 LTS. Os arquivos a serem instalados são:

  • libopenjp2-7 – 2.3.0-2build0.18.04.1;
  • libopenjp3d7 – 2.3.0-2build0.18.04.1;
  • e ibopenjpip7 – 2.3.0-2build0.18.04.1

Para fazer isso, basta abrir o aplicativo Software Update ou os diferentes centros de software disponíveis e atualizar os pacotes mencionados.

Fonte: Ubunlog

Written by Claylson Martins

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão.

A inteligência artificial consegue detectar fake news?

A inteligência artificial consegue detectar fake news?

windows-10-em-breve-tera-um-kernel-linux-real

A Microsoft traz o kernel Linux para o Windows