Vulnerabilidade afeta dispositivos My Cloud OS 5!

Jardeson Márcio
3 minutos de leitura

Uma vulnerabilidade crítica de segurança afetou dispositivos NAS My Cloud OS 5 da Western Digital. A exploração da falha permite que um invasor não autenticado obtenha acesso root aos dispositivos de destino, podendo abrir ainda mais o caminho para a execução remota de código.

Vulnerabilidade em dispositivos My Cloud OS 5

vulnerabilidade-afeta-dispositivos-my-cloud-os-5

De acordo com um comunicado recente da Western Digital, uma séria vulnerabilidade de segurança afeta os dispositivos NAS My Cloud OS 5. Conforme revelado, os dispositivos são afetados por uma vulnerabilidade de leitura/gravação fora dos limites do heap do Samba (uma reimplementação de software de protocolo de rede SMB gratuito que se integra a servidores Microsoft Windows) que permite a execução remota de código.

Essa vulnerabilidade geralmente afeta as versões do Samba usando o módulo VFS vfs_fruit, que inclui todas as versões anteriores à 4.13.17. O software também pode ser executado em Linux, Solaris e outros sistemas baseados em Unix, juntamente com o servidor e o cliente macOS. Essa vulnerabilidade crítica do Samba (CVE-2021-44142; CVSS 9.9) chamou a atenção no início deste ano.

Quando divulgou os detalhes dessa vulnerabilidade, o Samba afirmou no comunicado que a “falha falha específica existe na análise dos metadados do EA ao abrir arquivos em smbd… O problema em vfs_fruit existe na configuração padrão do módulo Fruit VFS usando fruit:metadata=netatalk ou fruit:resource=file”.

Exploração da vulnerabilidade

A exploração dessa vulnerabilidade pode permitir que um usuário remoto não autenticado execute códigos no dispositivo de destino. Qualquer pessoa com acesso de leitura/gravação aos atributos estendidos do arquivo pode explorar a falha.

Assim que a vulnerabilidade foi descoberta, os fornecedores também lançaram as correções com o Samba 4.13.17, 4.14.12 e 4.15.5. E agora, a Western Digital, a empresa americana de disco rígido e armazenamento de dados, divulgou a mesma vulnerabilidade que afeta seus dispositivos NAS. Especificamente, os dispositivos afetados incluem: My Cloud DL2100; My Cloud DL4100; My Cloud EX2100; My Cloud; WD Cloud; My Cloud PR2100; My Cloud PR2100; My Cloud PR4100; My Cloud EX4100; My Cloud EX2 Ultra; My Cloud Mirror Gen 2.

No entanto, a empresa de tecnologia já abordou a vulnerabilidade com o lançamento do My Cloud OS 5 Firmware versão 5.21.104. Essa atualização deve resolver o problema da vulnerabilidade. Ela está disponível para todos os produtos mencionados acima. Assim, os usuários podem simplesmente atualizar o firmware de seus dispositivos para receber a correção.

Se você ainda não atualizaou seu dispositivo, sugerimos que o faça o mais rápido possível.

Via: LatestHackingNews

Share This Article
Follow:
Jardeson é Mestre em Tecnologia Agroalimentar e Licenciado em Ciências Agrária pela Universidade Federal da Paraíba. Entusiasta no mundo tecnológico, gosta de arquitetura e design gráfico. Economia, tecnologia e atualidade são focos de suas leituras diárias. Acredita que seu dia pode ser salvo por um vídeo engraçado.