in

Vulnerabilidade afeta LibreOffice

Vulnerabilidade afeta LibreOffice
Vulnerabilidade afeta LibreOffice

Uma vulnerabilidade de Execução de Código Remoto (RCE) foi descoberta no LibreOffice. A falha afeta as versões da suíte de escritório no Windows e no Linux. Portanto, recomenda-se que os usuários atualizem para as versões mais recentes. Os patches já foram emitidos.

Descoberto pelo pesquisador de segurança Alex Inführ, a falha pode ser explorada com apenas um documento ODT malicioso. Este documento infectado inclui um código para executar uma macro com uma ação focada no mouse.

Em uma análise da vulnerabilidade em seu blog, a Inführ explica que as versões Windows e Linux do LibreOffice são afetadas. Os exploits de sucesso foram testados na versão 6.1.2.1.

O Document Foundation reconheceu o bug no CVE-2018-16858. Segundo a empresa, a falha já foi resolvida no LibreOffice 6.0.7 e 6.1.3. Então, a instalação de uma versão mais nova deve tecnicamente manter os usuários protegidos.

Anterior ao 6.0.7/6.1.3, o LibreOffice era vulnerável a um ataque de diretório transversal, onde era possível criar um documento que, quando aberto pelo LibreOffice, executaria um método python a partir de um script, em qualquer evento de documento comum. localização do sistema de arquivos, especificada em relação ao local de instalação do LibreOffice, observa o TDF.

OpenOffice vulnerável também

Vulnerabilidade afeta LibreOffice

Embora a vulnerabilidade já tenha sido resolvida no LibreOffice, parece que outros conjuntos de produtividade do Office também são afetados, incluindo o OpenOffice. De acordo com a BP, o OpenOffice ainda está sem correção.

O pesquisador de segurança confirma que o OpenOffice 4.1.6 é a única versão vulnerável a ataques. A empresa responsável reconheceu o problema. No entanto, não há uma data para ser aplicada a correção.

Confirmei por e-mail que tenho permissão para publicar os detalhes da vulnerabilidade, embora o OpenOffice ainda não esteja corrigido. O OpenOffice não permite passar parâmetros. Portanto, meu PoC não funciona, mas o caminho percorrido pode ser abusado para executar um script python de outro local no sistema de arquivos local, observa o pesquisador.

Então, recomenda-se que os usuários atualizem para a versão mais recente do LibreOffice o mais rápido possível. Já aqueles que usam o OpenOffice devem tentar ficar longe de documentos provenientes de fontes não confiáveis ??o máximo possível.

Fonte

Written by Claylson Martins

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão.

Trojan infecta máquinas rodando Linux e Mac

Trojan infecta máquinas rodando Linux e Mac

Asciinema - Grave e compartilhe suas sessões de terminais na voz

Asciinema – Grave e compartilhe suas sessões de terminais na voz