in

Canonical corrige novas falhas no Ubuntu

Não é repetição. Novos patches foram lançados para várias versões.

Canonical também corrige falhas da Intel

A Canonical lançou as principais atualizações de kernel do Linux para todas as séries de sistemas operacionais Ubuntu Linux suportados para lidar com dezenas de vulnerabilidades de segurança que afetam todas as arquiteturas suportadas no desktop, no servidor e na nuvem. Muitas delas já haviam sido divulgadas por aqui. Porém, há outros problemas resolvidos neste pacotão. Assim, a Canonical corrige novas falhas no Ubuntu.

Canonical corrige novas falhas no Ubuntu: são mais de 30

A correção está disponível para o Ubuntu 19.04 (Disco Dingo), Ubuntu 18.04 LTS (Bionic Beaver), Ubuntu 16.04 LTS (Xenial Xerus) e Ubuntu 14.04 ESM (Trusty Tahr).

Então, as novas atualizações de segurança do kernel Linux estão aqui para corrigir mais de 30 vulnerabilidades de segurança. Foram incluídos:

  • um estouro de buffer de heap descoberto no driver de dispositivo de LAN sem fio Marvell;
  • e um desreferenciamento de ponteiro NULL descoberto na implementação de Comunicação de campo próximo (NFC);
  • O patch de segurança também aborda uma vulnerabilidade de uso após a descoberta por Jann Horn, do Google Project Zero, no kernel Linux ao acessar entradas de LDT;
  • bem como uma condição de corrida ao realizar despejos principais;
  • Uma falha descoberta por Andrei Vlad Lutas e Dan Lutas em processadores x86, que manipulavam incorretamente as instruções da SWAPGS durante a execução especulativa, também foi corrigida.

Várias outras falhas de segurança são:

  • afetam a implementação do PowerPC dlpar do kernel Linux;
  • implementação de ptrace;
  • implementação de Bluetooth;
  • implementação de alarmtimer;
  • subsistema de dispositivos de barramento MDIO;
  • driver de dispositivo Empia EM28xx DVB USB;
  • implementação de classe de dispositivo de vídeo USB;
  • encapsulamento IP Appletalk;
  • assim como os sistemas de arquivos XFS, Btrfs, F2FS e HFS +.

Os usuários são convidados a atualizar suas instalações imediatamenteCanonical corrige novas falhas no Ubuntu

Se você estiver usando o Ubuntu 18.04 LTS (Bionic Beaver) ou o Ubuntu 16.04 LTS (Xenial Xerus) com o kernel do Linux 4.15, você deve atualizar suas instalações o mais rápido possível. A versão é para o linux-image 4.15.0-58.64.

Por outro lado, os usuários do Ubuntu 19.04 (Disco Dingo) e do Ubuntu 18.04.3 LTS (Bionic Beaver) que usam o kernel do Linux 5.0 devem atualizar seus sistemas para o linux-image 5.0.0-25.26.

Se você estiver usando o Ubuntu 16.04 LTS (Xenial Xerus) com o kernel Linux 4.4, você deve atualizar para o linux-image 4.4.0-159.187. 

Novas versões de kernel também estão disponíveis para sistemas Amazon Web Services (AWS), sistemas Microsoft Azure Cloud, sistemas Google Cloud Platform (GCP), sistemas Google Container Engine (GKE), sistemas Oracle Cloud, processadores Snapdragon, sistemas Raspberry Pi 2, ambientes de nuvem e processadores OEM.

Fonte: Softpedia

Escrito por Claylson Martins

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão.

Linux 5.4-rc4 chega como outro candidato normal

Kernel Linux 5.4 apresenta mais novidades

Grande falha de segurança Bluetooth deixa milhões de dispositivos vulneráveis

Grande falha de segurança Bluetooth deixa milhões de dispositivos vulneráveis