in

Canonical lança atualizações de segurança do kernel

Ubuntu 19.04, 18.04 LTS e 16.04 LTS são afetados.

Canonical corrige a regressão do kernel do Linux 4.15 no Ubuntu 18.04 LTS e 16.04 LTS

A Canonical lançou as principais atualizações de segurança do kernel Linux para todos os sistemas operacionais Ubuntu suportados. Assim, o objetivo foi solucionar até 28 vulnerabilidades de segurança. Então, a Canonical lança atualizações de segurança do kernel.

Vulnerabilidade faz Canonical lançar atualizações de segurança do kernel

A vulnerabilidade acaba afetando os kernels Linux 5.0, 4.15 e 4.4 do Ubuntu 19.04 (Disco Dingo), Ubuntu 18.04 LTS (Bionic Beaver) e Ubuntu 16.04 LTS (Xenial Xerus).

O problema mais crítico (CVE-2019-10638) corrigido nesta nova atualização de segurança foi descoberta por Amit Klein e Benny Pinkas. Eles perceberam uma vulnerabilidade no kernel Linux ao randomizar os valores de ID de IP gerados para protocolos de rede sem conexão. Isso poderia permitir que um invasor remoto rastreie determinados dispositivos Linux.

Também descoberta por Amit Klein e Benny Pinkas, a atualização de segurança elimina outra vulnerabilidade crítica (CVE-2019-10639) no kernel Linux. Porém, afeta apenas o kernel Linux 4.15 usado no Ubuntu 18.04 LTS (Bionic Beaver) e Ubuntu 16.04 LTS (Xenial Xerus). Isso pode permitir que um invasor remoto explore outra vulnerabilidade no kernel Linux, pois o local dos endereços do kernel pode ser exposto pela implementação de protocolos de rede sem conexão.

Outros problemas corrigidos

Canonical lança atualizações de segurança do kernel

Também foram corrigidos dois outros problemas importantes. Primeiramente, uma falha de segurança (CVE-2018-19985) descoberta por Hui Peng e Mathias Payer no driver Option USB High Speed ??do kernel do Linux. Depois, um problema (CVE-2019-0136) no driver de dispositivo Intel Wi-Fi ao validar determinado TDLS (Tunneled Direct Link Setup). Este permitiria que um invasor fisicamente próximo cause uma negação de serviço (ataque de DoS) e trave o sistema ou desconecta o Wi-Fi.

Entre outros problemas corrigidos nesta grande nova atualização de segurança do kernel Linux, podemos mencionar dois problemas no driver de disquete que leva à divisão por zero ou sobrecorrente de buffer, vulnerabilidades de loop infinito no driver virtio net e no agendador de processos do kernel do CFS Linux.

Também há vulnerabilidade de desreferência de ponteiro nulo no driver LSI Logic MegaRAID, bem como problemas que afetam a implementação Bluetooth UART do kernel do Linux e o driver de entrada do tablet GTCO.

Além disso, é abordada uma condição de corrida no driver de dispositivo DesignWare USB3 DRD Controller do kernel Linux, uma leitura fora dos limites no driver QLogic QEDI iSCSI Initiator, um bug no driver de dispositivo de rádio Raremono AM/FM/SW, um erro duplo-livre no driver de dispositivo USB Rio 500, bem como nas condições de corrida no subsistema ALSA (Advanced Linux Sound Architecture), driver de dispositivo USB YUREX, driver de dispositivo CPiA2 video4linux e driver de dispositivo Softmac USB Prism54.

Os usuários devem atualizar seus sistemas imediatamente

Uma vulnerabilidade de uso após livre descoberta na implementação Appletalk do kernel Linux, bem como problemas no driver do dispositivo receptor USB MDiano da Siano, driver do dispositivo USB POD Line 6, especificação do protocolo Bluetooth BR/EDR e implementação CAN, também foram abordados neste atualização de segurança. 

Portanto, todos os usuários do Ubuntu são convidados a atualizar suas instalações para as novas versões do kernel Linux o mais rápido possível.

Assim, os usuários do Ubuntu 19.04 e Ubuntu 18.04.3 LTS que usam o kernel Linux 5.0 HWE (Hardware Enablement) devem atualizar para linux-image 5.0.0-27.28;

Os usuários Ubuntu 18.04 LTS e Ubuntu 16.04.6 LTS usando o kernel Linux 4.15 HWE precisam atualize seus sistemas para linux-image 4.15.0-60.67;

Os usuários do Ubuntu 16.04 LTS que usam o kernel Linux 4.4 também terão que atualizar para a imagem linux 4.4.0-161.189.

Written by Claylson Martins

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão.

Firefox 69 sai com proteção aprimorada de rastreamento para maior privacidade e segurança

Firefox 69 sai com proteção aprimorada de rastreamento para maior privacidade e segurança

KDE Plasma 5.16 Desktop chega ao fim da vida útil

KDE Plasma 5.16 Desktop chega ao fim da vida útil