in

Canonical lança patch de segurança do Kernel

Afeta o Ubuntu 19.04, 18.10 e 18.04 LTS. A mudança afeta sistemas PowerPC Ubuntu de 64 bits

Canonical lança patch de segurança do Kernel

A Canonical lançou uma nova atualização de segurança do kernel Linux para várias de suas versões suportadas do Ubuntu. O objetivo é resolver um problema de segurança que afeta os sistemas PowerPC de 64 bits. Assim, a Canonical lança patch de segurança do Kernel.

Versões afetadas pelo patch de segurança do Kernel lançado pela Canonical

Canonical lança patch de segurança do Kernel

A mudança afeta os sistemas operacionais Ubuntu 19.04 (Disco Dingo), Ubuntu 18.10 (Cosmic Cuttlefish) e Ubuntu 18.04 LTS (Bionic Beaver). Assim, o novo patch de segurança do kernel Linux corrige uma vulnerabilidade (CVE-2019-12817) em PowerPC de 64 bits (ppc64el). Este problema permite que um atacante acesse o conteúdo da memória ou corrompa a memória de outros processos.

Descobriu-se que o kernel do Linux não separava corretamente certos mapeamentos de memória ao criar novos processos de espaço do usuário em sistemas Power (ppc64el) de 64 bits. Um invasor local poderia usar isso para acessar o conteúdo da memória ou causar corrupção de memória de outros processos no sistema, diz o aviso de segurança.

Os usuários são convidados a atualizar seus sistemas imediatamente

Canonical lança patch de segurança do Kernel

Se você estiver usando os sistemas operacionais Ubuntu 19.04 (Disco Dingo), Ubuntu 18.10 (Cosmic Cuttlefish) ou Ubuntu 18.04 LTS (Bionic Beaver) em um sistema PowerPC (ppc64el) de 64 bits, é recomendado atualizar o kernel. Porém, fique atento a cada versão. Assim, há

  • a linux-image -5.0.0-19.20 no Ubuntu 19.04;
  • linux-image-4.18.0-24.25 no Ubuntu 18.10;
  • e linux-image-4.18.0-24.25 ~ 18.04.1 no Ubuntu 18.04.1 LTS ou posterior.

Para atualizar seu sistema, siga as instruções fornecidas pela Canonical em https://wiki.ubuntu.com/Security/Upgrades.

Por favor, lembre-se de reiniciar seu sistema após aplicar a nova versão do kernel. Somente assim para que o problema de segurança seja corrigido. Além disso, você pode precisar recompilar e reinstalar quaisquer módulos de kernel de terceiros que você possa ter instalado.

Se você não desinstalou manualmente os meta-pacotes de kernel padrão linux-generic, linux-generic-lts-RELEASE, linux-virtual e linux-powerpc, o mecanismo de atualização do sistema cuidará automaticamente dos seus módulos de kernel de terceiros. E lembre-se de sempre manter seu sistema operacional e instalar os aplicativos atualizados.

Written by Claylson Martins

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão.

Fedora 31 não terá mais pacotes do Linux Kernel i686

Fedora 31 não terá mais pacotes do Linux Kernel i686

Microsoft e Intel prometem não abandonar dispositivos da Huawei

Microsoft e Intel prometem não abandonar dispositivos da Huawei