in

Canonical libera atualização do Kernel para corrigir 11 problemas

Canonical libera atualização do Kernel para corrigir 11 problemas

A Canonical publicou uma importante atualização de segurança do kernel Linux para a série de sistemas operacionais Ubuntu 18.04 LTS (Bionic Beaver). A atualização é para solucionar 11 vulnerabilidades de segurança descobertas recentemente por vários pesquisadores independentes. Veja neste post que a Canonical libera atualização do Kernel para corrigir 11 problemas.

Vários problemas de segurança foram descobertos no kernel Linux utilizado pela Canonical Ubuntu LTS. Não somente a distro principal foi afetada ms também as variantes do sistema operacional 18.04 (Bionic Beaver). Assim,  foram incluídos Kubuntu, Xubuntu, Lubuntu, Ubuntu GNOME, Ubuntu Budgie, Ubuntu Kylin, e Ubuntu Studio, bem como outros tipos de terceiros baseados neles.

As vulnerabilidades

Um total de onze vulnerabilidades de segurança foram abordadas nesta grande atualização do kernel, sete das quais são falhas (CVE-2018-10876CVE-2018-10877,  CVE-2018-10878CVE-2018-10879CVE-2018-10880,  CVE-2018-10882 e  CVE-2018-10883) descobertos por Wen Xu na implementação do sistema de arquivos EXT4 do kernel Linux.

Essas vulnerabilidades vão de uso livre de buffer e estouro de buffer a gravações fora dos limites. Elas podem permitir que atacantes executem código arbitrário ou travem o sistema por meio de um ataque de negação de serviço. Isto é feito utilizando uma imagem EXT4 criada com códigos maliciosos montado na máquina vulnerável.

Também é abordada uma condição de corrida (CVE-2018-14625) descoberta na implementação da família de endereços vsock do kernel Linux. Isso pode levar a uma condição de uso livre, permitindo que um invasor local exponha informações confidenciais na máquina virtual convidada (máquina host memória do kernel).

Outros problemas

Dois problemas de segurança (CVE-2018-16882 e CVE-2018-19407) que afetam a implementação da KVM (Kernel-based Virtual Machine), descoberta por Cfir Cohen e Wei Wu, também foram corrigidos. Isso poderia permitir que um invasor em uma máquina virtual convidada ganhasse privilégios administrativos na máquina host. Do mesmo modo, poderia causar falhas no sistema.

Por último, mas não menos importante, a atualização de segurança corrige duas vulnerabilidades (CVE-2018-17972 e CVE-2018-18281) descobertas por Jann Horn do Google Project Zero na implementação do sistema de arquivos procfs do kernel Linux e na chamada de sistema mremap (). Isso poderia permitir que invasores expusessem informações confidenciais ou executam código arbitrário.

Usuários do Ubuntu 18.04 LTS devem atualizar imediatamente

A atualização de segurança também corrige um problema (CVE-2018-9516) descoberto na interface de depuração do subsistema HID do kernel Linux. Ele executava indevidamente a verificação de limites sob certas condições. Então, um invasor com acesso ao utilitário debugfs obtivesse privilégios adicionais ou negação de serviço.

A Canonical pede a todos os usuários do Ubuntu 18.04 LTS (Bionic Beaver) para atualizar suas instalações imediatamente. A versão é  o kernel linux-image 4.15.0-44.47. Ele está disponível para instalações genéricas, lpae e low-latency de 64 bits e 32 bits, bem como para processadores Snapdragon.

Para atualizar o seu sistema, execute o comando

sudo apt update 
sudo apt full-upgrade

Depois reinicie o seu PC ou siga as instruções fornecidas pela Canonical em  https://wiki.ubuntu.com/Security/Upgrades.

Usuários do Ubuntu 18.04.1 LTS ou posterior usando a série de kernel do Linux 4.18 também devem atualizar.  Então, neste caso, a versão é linux-image 4.18.0-14.15 ~ 18.04.1.

Fonte

Written by Claylson Martins

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão.

Firefox 67 irá adicionar suporte para rodar diferentes instalações do Firefox lado a lado

Firefox 65 é lançado com camada extra de proteção

Como adicionar temas no LibreOffice

LibreOffice 6.2 com lançamento previsto para Fevereiro apresentará uma nova interface com guias