Categorias

Android

Games

Notícias Linux

Tutoriais Linux

Vídeos

Tutoriais Linux

04/12/2020 às 11:30

16 min leitura

Avatar Autor
Por Jardeson Márcio

Como instalar o Fluent Reader no Ubuntu, Linux Mint, Fedora, Debian, Manjaro, Arch Linux, KDE Neon, openSUSE, CentOS e Red Hat Enterprise Linux!

como-instalar-o-fluent-reader-no-ubuntu-linux-mint-fedora-debian-manjaro-arch-linux-kde-neon-opensuse-centos-e-red-hat-enterprise-linux

O Fluent Reader é um leitor RSS de desktop moderno desenvolvido com Electron, React e Fluent UI. Ele tem uma IU moderna inspirada no Fluent Design System com suporte para modo totalmente escuro. Com ele é possível a leitura local ou sincronizada com serviços auto-hospedados por meio da API Fever. Saiba como instalar o Fluent Reader no Linux.

Um outra característica do Fluent Reader é a importação ou exportação de arquivos OPML, backup e restauração de dados de aplicativos completos. Com ele é possível a leitura do conteúdo completo com a visualização de artigo integrada ou carregando páginas da web por padrão. O Fluent Reader ainda apresenta outras características que o deixam ainda mais completo.

como-instalar-o-fluent-reader-no-ubuntu-linux-mint-fedora-debian-manjaro-arch-linux-kde-neon-opensuse-centos-e-red-hat-enterprise-linux

Instalando o Fluent Reader no Ubuntu, Kubuntu, Xubuntu e derivados!

Para instalar o Fluent Reader no Ubuntu 20.10, Ubuntu 20.04, Ubuntu 19.04, Ubuntu 18.04, Ubuntu 18.10, Ubuntu 16.04 ou superior. Inclusive você também pode instalar o Fluent Reader no Linux Mint sem nenhum problema execute o comando abaixo:

sudo snap install fluent-reader –candidate

Instalando o Fluent Reader no KDE Neon

Para instalar o Fluent Reader no KDE Neon execute apenas o comando abaixo:

sudo snap install fluent-reader –candidate

Instalando o Fluent Reader no Fedora e derivados!

Para instalar o Fluent Reader no Fedora, execute os comandos abaixo. Lembrando que caso você já tenha o suporte ao Snap habilitado no Fedora, pule para o passo 3, o de instalação do pacote:

Passo 1 – Instalar o Snapd:

sudo dnf install snapd

Após executar o comando acima, lembre-se encerrar a sessão ou reiniciar o computador! Em seguida, vamos criar um link simbólico para ativar o suporte ao Snap clássico:

Passo 2 – Criar link simbólico:

sudo ln -s /var/lib/snapd/snap /snap

E agora, vamos executar o comando para instalar o Fluent Reader no Fedora ou derivados:

Passo 3 – Agora vamos executar o comando para instalar o Fluent Reader no Fedora ou derivados:

sudo snap install fluent-reader –candidate

Instalando o Fluent Reader no Debian e derivados!

Para instalar o Fluent Reader no Debian, execute os comandos abaixo. Caso você já tenha  Snap ativado e habilitado no seu Debian, pule para o passo 2, que seria da instalação:

Passo 1 – Atualizar os repositório e instalar o Snapd:

apt update
apt install snapd

E agora, vamos executar o comando para instalar o Fluent Reader no Debian ou derivados. Observe que o comando abaixo está com o sudo, caso você não o tenha habilitado, remova o sudo e instalar usando o ROOT mesmo:

Passo 2 – Agora vamos executar o comando para instalar o Fluent Reader no Debian e derivados:

sudo snap install fluent-reader –candidate

Instalando o Fluent Reader no Arch Linux, Manjaro e derivados!

Para instalar o Fluent Reader no Arch Linux, Manjaro e derivados, execute os comandos abaixo, caso você já tenha o suporte ao Snap habilitado pule a etapa de ativação do Snap direto para o comando de instalação.

Passo 1 – Ativar o suporte Snap no Arch Linux, Manjaro e derivados:

sudo pacman -S snapd
sudo systemctl enable –now snapd.socket
sudo ln -s /var/lib/snapd/snap /snap

Passo 2 – Agora vamos executar o comando para instalar o Fluent Reader no Arch Linux, Manjaro e derivados:

sudo snap install fluent-reader –candidate

Instalando o Fluent Reader no CentOS e derivados!

Para instalar o Fluent Reader no CentOS, execute os comandos abaixo. Vamos utilizar o repositório EPEL. Caso você já tenha o repositório adicionado pule para o passo 2.

Nota:Vale lembrar que uma vez que você adicione o  repositório e habilite o suporte ao Snap no CentOS, você não precisará mais fazer isso sempre que for instalar um pacote Snap.

Passo 1 – Adicionar o repositório de software EPEL ao CentOS:

sudo yum install epel-release

Passo 2 – Instalar o pacote responsável pela compatibilidade com pacotes Snap. Caso você já tenha o suporte habilitado no CentOS para o Snap, pule para o passo 5, o de instalação do Software:

sudo yum install snapd

Passo 3 – Habilitar o serviço no sistema:

sudo systemctl enable –now snapd.socket

Passo 4 – Ativar o suporte ao Snap clássico vamos criar um link simbólico:

sudo ln -s /var/lib/snapd/snap /snap

Passo 5 – Agora, vamos executar o comando para instalar o Fluent Reader no CentOS ou derivados:

sudo snap install fluent-reader –candidate

Instalando o Fluent Reader no openSUSE e derivados!

Para instalar o Fluent Reader no openSUSE, execute os comandos abaixo. Vamos utilizar um repositório. Caso você já tenha o suporte ao Snap instalado e habilitado no openSUSE, pule para o passo 5:

Passo 1 – Adicionar repositório:

Para openSUSE 15.0:

sudo zypper addrepo –refresh https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.0 snappy

Para openSUSE 15.1:

sudo zypper addrepo –refresh https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.1 snappy

Para openSUSE 15.2:

sudo zypper addrepo –refresh https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.2 snappy

Para openSUSE 42.3:

sudo zypper addrepo –refresh https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_42.3 snappy

Para openSUSE Tumbleweed:

sudo zypper addrepo –refresh https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.0 snappy

Nota: Caso você esteja utilizando uma versão diferente das propostas no momento da escrita deste artigo, basta trocar o final do link pela versão correspondente!

Passo 2 – Agora, vamos importar a chave do repositório e em seguida atualizar a nossa fonte de softwares:

sudo zypper –gpg-auto-import-keys refresh
sudo zypper dup –from snappy

Passo 3 – Vamos instalar o Snapd, e em seguida você precisa reiniciar a máquina para poder continuar:

sudo zypper install snapd

Passo 4 – Agora que você reiniciou a sua máquina, vamos habilitar e iniciar o serviço do Snap, a partir de agora, sempre que você precisar instalar um pacote Snap, basta ir direto para o comando de instalação:

sudo systemctl enable snapd
sudo systemctl start snapd

Caso você esteja usando a versão Tumbleweed, execute o comando abaixo:

sudo systemctl enable snapd.apparmor
sudo systemctl start snapd.apparmor

Passo 5 – E por fim, execute o comando de instalação do Fluent Reader no openSUSE:

sudo snap install fluent-reader –candidate

Instalando o Fluent Reader no Red Hat Enterprise Linux

Para instalar o Fluent Reader no Red Hat Enterprise Linux você precisa executar os comandos abaixo. Note que vamos precisar ativar o suporte Snap no Red Hat Enterprise Linux, então caso você já o tenha feito anteriormente, você pode pular o passo 1.

Passo 1 – Ativar o Snap no Red Hat Enterprise Linux, observe a versão do sistema antes de executar o comando:

Para RHEL 8, execute:

sudo dnf install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm sudo dnf upgrade

Para RHEL 7, execute:

sudo subscription-manager repos –enable “rhel-*-optional-rpms” –enable “rhel-*-extras-rpms” sudo yum update
sudo yum install snapd
sudo systemctl enable –now snapd.socket
sudo ln -s /var/lib/snapd/snap /snap

Passo 2 – Comando para instalar o Fluent Reader no Red Hat Enterprise Linux

sudo snap install fluent-reader –candidate

É isso, esperamos ter ajudado você a instalar o Fluent Reader no Linux!

Jardeson é Mestre em Tecnologia Agroalimentar e Licenciado em Ciências Agrária pela Universidade Federal da Paraíba. Entusiasta no mundo tecnológico, gosta de arquitetura e design gráfico. Economia, tecnologia e atualidade são focos de suas leituras diárias. Acredita que seu dia pode ser salvo por um vídeo engraçado.

Últimos artigos

Newsletter

Receba nossas atualizações!

Newsletter

Receba nossas atualizações!
  • Este campo é para fins de validação e não deve ser alterado.