Notícias

13/01/2022 às 08:00

6 min leitura

Avatar Autor
Por Claylson Martins

Flatpak 1.12.3 tem correções de segurança e novas configurações de PulseAudio

Duas versões do Flatpak receberam correção.

Flatpak 1.12.3 tem correções de segurança e novas configurações de PulseAudio

Finalmente saiu a mais recente versão 1.12.3 do Flatpak com correções de segurança importantes e novas configurações de PulseAudio. O anúncio é do desenvolvedor Alexander Larsson. Esta foi a terceira manutenção desta série do programa. O Flatpak possui uma boa estrutura de distribuição e sandboxing de aplicativos Linux. Todos são de código aberto.


Desta vez, o Flatpak 1.12.3 corrige dois problemas críticos de segurança. É o caso do CVE-2021-4386. Esta falha pode permitir que um repositório malicioso envie metadados de aplicativos inválidos. Assim, as permissões do aplicativo acabam ocultas durante a instalação.

Do mesmo modo, foram resolvidos problemas que afetavam o componente do Flatpak chamado flatpak-builder. Isso poderia causar o flatpak-builder --mirror-screenshots-url, permitindo o acesso indevido de arquivos de fora do diretório principal de compilação.

A solução disso está no próprio flatpak ao tornar o --nofilesystem=host--nofilesystem=home mais forte. Anteriormente, eles apenas removeram o acesso ao local específico, ou seja, negaram o --nofilesystem=host — filesystem=host, mas não o --filesytem=/some/dir, diz a nota de lançamento

Flatpak 1.12.3 tem correções de segurança e novas configurações de PulseAudio

Flatpak 1.12.3 tem correções de segurança e novas configurações de PulseAudio
Flatpak 1.12.3 tem correções de segurança e novas configurações de PulseAudio

Esta é uma pequena alteração no comportamento, a partir de uma substituição com essas opções específicas. No entanto, é provável que o novo comportamento tenha sido o esperado. Além dessas correções de segurança, a versão Flatpak 1.12.3 adiciona suporte para mais configurações de PulseAudio. São as mesmas do WSL2. Então, melhora o tratamento de atualizações de extensão de vários repositórios. Aperfeiçoa a saída de linha de comando para destinos não terminais. Por fim, corrige o comando flatpak run --session-bus.

Além disso, ele atualiza o preenchimento automático do bash. Então, ele deixa de funcionar em aliases de nome de comando. Também corrige anotações “Desde” em sinais FlatpakTransaction. Por fim, adiciona a capacidade de verificar somas de verificação de caches de resumo. Então, deve melhorar o tratamento de corrupção de arquivos locais.

Entre outras mudanças, o Flatpak 1.12.3:

  • melhora o download de dados extras. Assim, trabalha adequadamente com codificações de conteúdo compactado e corrige somas de verificação;
  • e adiciona pequenas melhorias aos comandos de lista, reparo e pesquisa.
  • A atualização corrige a instalação de aplicativos Flatpak com IDs renomeados;
  • Corrige uma regressão nas atualizações de controles remotos não enumerados;
  • corrige a construção com PyParsing 3.0.4 ou posterior;
  • adiciona mais testes;
  • e atualiza a documentação e vários traduções.

Você pode baixar o Flatpak 1.12.3 agora mesmo na página do projeto no GitHub. Neste caso, é preciso fazer a compilação. No entanto, se você não tem pressa nem conhecimento suficiente para compilar, o melhor é aguar até que a atualização chegue aos repositórios oficiais de sua distribuição Linux.

Além disso, outra novidade é a chegada do Flatpak 1.10.6. Serve para usuários que ainda estão com a série Flatpak 1.10. Neste caso, a versão também corrigiu os problemas que falamos acima. Além disso, ganhou mensagens de diagnóstico aprimoradas quando as regras de secomp não podem ser aplicadas. Também houve o tratamento de erros para o syscalls. Eles são bloqueadas quando não estão usando o argumento --devel.

Via 9to5Linux

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão. Nas horas não muito vagas, professor, fotógrafo, apaixonado por rádio e natureza.

Mais lidas

Últimos posts

Newsletter

Receba nossas atualizações!

Newsletter

Receba nossas atualizações!
  • Este campo é para fins de validação e não deve ser alterado.
×