Categorias

o-android-13-tem-codinome-interno-vazado-a-aposta-agora-e-a-sobremesa-tiramisu

Android

Games

Notícias

Tutoriais Linux

Vídeos

Notícias

06/09/2021 às 08:00

7 min leitura

Avatar Autor
Por Claylson Martins

Linux 5.15 habilita “-Werror” por padrão para todas as compilações de kernel

Linux 5.15 habilita "-Werror" por padrão para todas as compilações de kernel

Uma mudança feita por Linus Torvalds e fundida agora para o Linux 5.15 está habilita o sinalizador de compilador “-Werror” por padrão para todas as compilações de kernel. O sinalizador do compilador “-Werror” trata todos os avisos como erros de construção. Ao promover todos os avisos de erros, ele obriga os desenvolvedores a garantir que tais avisos de construção que podem passar despercebidos ou apenas vagamente preocupados pelos desenvolvedores agora tratá-los com prioridade, visto que interromperá o processo de construção. 

Muitos projetos de software já usam “-Werror” por padrão para garantir um melhor controle de qualidade para garantir que os avisos sejam tratados, mas a maioria deles tende a não ser do tamanho do kernel do Linux.

Linux 5.15 habilita “-Werror” por padrão para todas as compilações de kernel

Linus Torvalds comentou com a seguinte mudança:

Devemos sempre ter uma compilação limpa e desabilitaremos os avisos ansiosos específicos conforme necessário, se não pudermos corrigi-los. Mas embora eu aplique isso religiosamente em minha própria árvore, isso não é imposto por vários robôs de construção que não necessariamente relatam avisos. Portanto, isso apenas torna ‘-Werror’ um sinalizador de compilador padrão.

No entanto, este patch também adiciona WERROR como um switch Kconfig. Isso permite desabilitar o sinalizador” -Werror “caso novas versões do compilador introduzam novos avisos que não podem ser corrigidos imediatamente pelo kernel ou outros problemas seletivos onde fazer um aviso- kernel livre não é viável. A opção WERROR é habilitada por padrão para todas as compilações de kernel.

Linus terminou a mensagem de patch com a seguinte mensagem: “Espero que isso signifique que recebo menos solicitações de pull com novos avisos que não foram percebidos por várias automações que temos em vigor. Bata na madeira.

Rolagem de alta resolução no Linux e suporte para mouse Apple Magic Mouse no Linux 5.15

Linux 5.15 habilita "-Werror" por padrão para todas as compilações de kernel

A rolagem de alta resolução é trabalhada há muitos anos no Linux. Isso inclui também o trabalho para ela em torno do X Input, a biblioteca libinput usada pelos sistemas X.Org e Wayland, e o lado do driver do kernel para os dispositivos HID/entrada para suportar isto. 

O trabalho de espaço do usuário mais recente é o suporte à roda de rolagem de alta resolução no próximo lançamento do libinput. Separadamente, o Linux 5.15 agora oferece suporte adicional para rolagem de alta resolução com o mouse Apple Magic Mouse.

Peter Hutterer da Red Hat que atua como especialista em entrada do Linux e é responsável por grande parte do trabalho de rolagem de alta resolução lançado libinput 1.18-rc1. Com este novo instantâneo, há suporte para gestos de espera e roda de rolagem de alta resoluçãoApoio, suporte. Peter observa naquele anúncio que a rolagem da roda de alta resolução substitui a API anterior do eixo do ponteiro.

No blog de Peter, ele escreveu mais sobre o suporte da roda de rolagem de alta resolução. Via Twitter, Peter também compartilhou um vídeo mostrando a suavidade desse suporte aprimorado da roda de rolagem:

E então no suporte de alta resolução em geral, o Linux 5.15 adiciona rolagem de alta resolução para o Apple Magic Mouse. O recurso HID também inclui suporte para dongles GHLive PS4, relatórios aprimorados da bateria da caneta e outros aprimoramentos para os vários drivers HID.

Via Phoronix

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão. Nas horas não muito vagas, professor, fotógrafo, apaixonado por rádio e natureza.

Últimos artigos

Newsletter

Receba nossas atualizações!

Newsletter

Receba nossas atualizações!
  • Este campo é para fins de validação e não deve ser alterado.