in

Ubuntu 16.04 LTS executando Linux 4.4 recebem nova atualização de segurança do kernel

Ubuntu 18.04 também recebeu o patch.

Ubuntu 20.10 Groovy Gorilla possui kernel Linux 5.8

Todos os sistemas operacionais baseados no Ubuntu 16.04 LTS e que estão executando o Linux 4.4 recebem uma nova atualização de segurança do kernel. O comunicado da nova atualização de kernel foi feito pela Canonical. Segundo a empresa, foram resolvidos dois problemas que afetavam a segurança da distribuição e todos os sabores derivados.

Um dos problemas foi classificado como CVE-2020-12771. Esta é uma falha descoberta no subsistema bcache do kernel Linux que pode permitir que um invasor local cause uma negação de serviço. O segundo problema é o CVE-2020-15393, uma vulnerabilidade descoberta por Kyungtae Kim no driver de teste USB. Esta falha permite que um invasor próximo fisicamente cause uma negação de serviço (exaustão de memória).

Ubuntu 16.04 LTS executando Linux 4.4 recebem nova atualização de segurança do kernel

Ubuntu 16.04 LTS executando Linux 4.4 recebem nova atualização de segurança do kernel

Todos os usuários do Ubuntu 16.04 LTS (Xenial Xerus) que executam o kernel Linux 4.4 padrão devem atualizar suas instalações para as novas versões do kernel:

  • linux-image 4.4.0-187.217 para sistemas de 32 bits, 64 bits e PowerPC;
  • linux-image -raspi2 4.4.0-1137.146 para sistemas Raspberry Pi (V7);
  • o linux-image-aws 4.4.0-1112.124 para sistemas Amazon Web Services (AWS);
  • linux-image-snapdragon 4.4.0-1141.149 para processadores Qualcomm Snapdragon;
  • linux-image-kvm 4.4.0-1078.85 para ambientes em nuvem.

Um novo kernel HWE (Hardware Enablement) do Ubuntu 16.04 LTS (Xenial Xerus) também foi lançado para usuários do Ubuntu 14.04 ESM (Trusty Tahr) executando o kernel Linux 4.4.

Mesmo problema, outras versões

Também hoje, o problema CVE-2020-12771 foi corrigido nos pacotes do kernel Linux 5.0 do Ubuntu 18.04 LTS (Bionic Beaver) para o Google Container Engine (GKE) e sistemas OEM. Os usuários devem atualizar para linux-image-gke 5.0.0-1046.47 e linux-image-oem-osp1 5.0.0-1067.72 .

Para fazer a atualização é muito simples. Abra um terminal e digite o comando:

A outra opção é atualizar via execução do utilitário Software Updater. Após esse processo, o computador deve ser reinicializado. Somente assim as mudanças serão aplicadas. Além disso, tenha em mente que devido a uma mudança inevitável de ABI, você também terá que reconstruir e reinstalar quaisquer módulos de kernel de terceiros que possa ter instalado.

Escrito por Claylson Martins

Jornalista com pós graduações em Economia, Jornalismo Digital e Radiodifusão. Nas horas não muito vagas, professor, fotógrafo, apaixonado por rádio e natureza.